JS Console "Copy" results in lone \n's on clipboard

RESOLVED WONTFIX

Status

Toolkit Graveyard
Error Console
RESOLVED WONTFIX
17 years ago
2 years ago

People

(Reporter: neil@parkwaycc.co.uk, Unassigned)

Tracking

Details

(Reporter)

Description

17 years ago
Using Build ID: 2002010303
Steps to reproduce problem:
1. Open JS Console
2. Copy an error or warning
3. Paste into Notepad

Expected result: each component on a new line

Actual results: each component separated with  (\n really)
this is XP, fwiw, and happens in Mac NS6.2 so it's not a recent regression. The
clipboard will only correctly translate DOM line-endings (LF) into platform
line-endings. Anything else will cause problems.
OS: Windows 95 → All
Hardware: PC → All

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Comment 2

15 years ago
So what's the status of this? It still appears in 1.5 beta.
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
Assignee: hewitt → nobody
Status: ASSIGNED → NEW
QA Contact: jrgmorrison → error-console
Target Milestone: mozilla1.1alpha → ---

Comment 3

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 4

9 years ago
Confirm that the problem still exists in the toolkit error console:
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9.1pre) Gecko/20090614 SeaMonkey/2.0b1pre

Natch: your error console rewrite uses \x0d\x0a right?
Status: UNCONFIRMED → NEW
Component: Error Console → Error Console
Depends on: 489736
Product: SeaMonkey → Toolkit
QA Contact: error-console → error.console
(In reply to comment #4)
ifdef'd to windows, yes. This will be fixed in bug 305206.
Depends on: 305206
No longer depends on: 489736
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
Can't reproduce in the Browser Console
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.