ReferenceError: target is not defined when performing a paste-and-search

RESOLVED FIXED in Firefox 40

Status

()

Firefox
Search
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: nhnt11, Assigned: nhnt11)

Tracking

39 Branch
Firefox 42
Points:
---

Firefox Tracking Flags

(firefox39 wontfix, firefox40 fixed, firefox41 fixed, firefox42 fixed, firefox-esr38 unaffected)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
Created attachment 8631253 [details] [diff] [review]
Patch

|target| here is defined in a separate block: https://dxr.mozilla.org/mozilla-central/source/browser/components/search/content/search.xml#525.
Attachment #8631253 - Flags: review?(adw)
Comment on attachment 8631253 [details] [diff] [review]
Patch

Review of attachment 8631253 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8631253 - Flags: review?(adw) → review+
Assignee: nobody → nhnt11
(Assignee)

Comment 2

2 years ago
Created attachment 8631259 [details] [diff] [review]
Patch v1.0.0.0.1 (Updated commit message)

Approval Request Comment
[Feature/regressing bug #]: 1120957
[User impact if declined]: Users see an error in the console when performing a paste-and-search, and their search won't have a source set in Telemetry.
[Describe test coverage new/current, TreeHerder]: none
[Risks and why]: very low risk, moves a variable declaration to an outer block.
[String/UUID change made/needed]: none
Attachment #8631253 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8631259 - Flags: review+
Attachment #8631259 - Flags: approval-mozilla-beta?
Attachment #8631259 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 3

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/88778e97874f
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/88778e97874f
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
status-firefox39: --- → wontfix
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox-esr38: --- → unaffected
Comment on attachment 8631259 [details] [diff] [review]
Patch v1.0.0.0.1 (Updated commit message)

Low risk, easy fix, taking it.
Attachment #8631259 - Flags: approval-mozilla-beta?
Attachment #8631259 - Flags: approval-mozilla-beta+
Attachment #8631259 - Flags: approval-mozilla-aurora?
Attachment #8631259 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/9283521d2c15
status-firefox41: affected → fixed
https://hg.mozilla.org/releases/mozilla-beta/rev/e3ba0f07cffa
status-firefox40: affected → fixed
Duplicate of this bug: 1158040
You need to log in before you can comment on or make changes to this bug.