the api documentation should provide descriptions of endpoints and fields

RESOLVED DUPLICATE of bug 1177559

Status

RESOLVED DUPLICATE of bug 1177559
4 years ago
3 years ago

People

(Reporter: glob, Unassigned)

Tracking

Details

the api documentation at https://treeherder.mozilla.org/docs/ just contains the method names and parameters.  there's no information about what each endpoint actually does, nor what the parameters and response fields contain.

eg.

/api/repository/{pk}/ 

its description is "ViewSet for the refdata Repository model" which isn't helpful.

i can see that it takes a string parameter which is a path, but i'm not sure what the path actually represents.

i can see the response fields, but there's no description for what they contain.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1177559
You need to log in before you can comment on or make changes to this bug.