TEST-UNEXPECTED-FAIL: /builds/slave/test/build/application/thunderbird/xpcshell: error while loading shared libraries: liblgpllibs.so: cannot open shared object file: No such file or directory

RESOLVED FIXED in Thunderbird 44.0

Status

MailNews Core
Testing Infrastructure
RESOLVED FIXED
2 years ago
11 months ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

unspecified
Thunderbird 44.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

2 years ago
01:33:28  WARNING -  TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarm.js | xpcshell return code: 127
01:33:28     INFO -  TEST-INFO took 22ms
01:33:28     INFO -  >>>>>>>
01:33:28     INFO -  PROCESS | 10055 | /builds/slave/test/build/application/thunderbird/xpcshell: error while loading shared libraries: liblgpllibs.so: cannot open shared object file: No such file or directory
01:33:28     INFO -  <<<<<<<
01:33:28     INFO -  TEST-START | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js
01:33:28  WARNING -  TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | xpcshell return code: 127
01:33:28     INFO -  TEST-INFO took 22ms
01:33:28     INFO -  >>>>>>>
01:33:28     INFO -  PROCESS | 10058 | /builds/slave/test/build/application/thunderbird/xpcshell: error while loading shared libraries: liblgpllibs.so: cannot open shared object file: No such file or directory
01:33:28     INFO -  <<<<<<<
...

seems there has been a change in the LGPL code or some such.  

apparently it requires a package-manifest.in fix in Mailnews.
(Assignee)

Comment 1

2 years ago
Forgot to mention:

 Ubuntu VM 12.04 comm-central opt test xpcshell on Thu Jul 9, 16:29:19.

slave:  tst-linux32-spot-198
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 10

2 years ago
Created attachment 8631492 [details] [diff] [review]
package-manifest.in change for im/ (v1)
Attachment #8631492 - Flags: review?(clokep)
(Assignee)

Comment 11

2 years ago
Created attachment 8631493 [details] [diff] [review]
package-manifest.in change for mail/ (v1)
Attachment #8631493 - Flags: review?(rkent)
(Assignee)

Comment 12

2 years ago
Created attachment 8631494 [details] [diff] [review]
package-manifest.in change for suite/ (v1)
Attachment #8631494 - Flags: review?(bugzilla)
(Assignee)

Comment 13

2 years ago
Created attachment 8631497 [details] [diff] [review]
package-manifest.in change for mail/ (v2)
Attachment #8631493 - Attachment is obsolete: true
Attachment #8631493 - Flags: review?(rkent)
Attachment #8631497 - Flags: review?(rkent)
Comment on attachment 8631497 [details] [diff] [review]
package-manifest.in change for mail/ (v2)

Taking this review so rkent can concentrate on the legal side of things, r=philipp
Attachment #8631497 - Flags: review?(rkent) → review+
(Assignee)

Comment 15

2 years ago
Comment on attachment 8631497 [details] [diff] [review]
package-manifest.in change for mail/ (v2)

Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/0147beb92bfe

Comment 16

2 years ago
Comment on attachment 8631494 [details] [diff] [review]
package-manifest.in change for suite/ (v1)

Sounds easy enough. ;-)
Attachment #8631494 - Flags: review?(bugzilla) → review+
(Assignee)

Comment 17

2 years ago
Comment on attachment 8631494 [details] [diff] [review]
package-manifest.in change for suite/ (v1)

Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/410e376f4a32
Comment on attachment 8631492 [details] [diff] [review]
package-manifest.in change for im/ (v1)

Review of attachment 8631492 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8631492 - Flags: review?(clokep) → review+

Comment 19

2 years ago
Is the solution to this bug supposed to fix the current comm-central Seamonkey build breakage?

c:/seamonkey/comm-central/suite/profile/migration/src/nsNetscapeProfileMigratorBase.cpp(50) : error C3861: 'do_GetService': identifier not found

Doesn't do it even with the latest mail patch. If not I would file a new bug.

Comment 20

2 years ago
Always this error ... :-(

nsThreadUtils.cpp
nsWindowsShellService.cpp
c:/Users/Vlada/comm-central/suite/profile/migration/src/nsSuiteProfileMigratorUtils.cpp(121) : error C2065: 'nsIProperties' : undeclared identifier
c:/Users/Vlada/comm-central/suite/profile/migration/src/nsSuiteProfileMigratorUtils.cpp(121) : error C2923: 'nsCOMPtr' : 'nsIProperties' is not a valid template type argument for parameter 'T'
c:/Users/Vlada/comm-central/suite/profile/migration/src/nsSuiteProfileMigratorUtils.cpp(122) : error C3861: 'do_GetService': identifier not found
c:/Users/Vlada/comm-central/suite/profile/migration/src/nsSuiteProfileMigratorUtils.cpp(122) : error C2514: 'nsCOMPtr' : class has no constructors
        ../../../../dist/include\nsCOMPtr.h(346) : see declaration of 'nsCOMPtr'
c:/Users/Vlada/comm-central/suite/profile/migration/src/nsSuiteProfileMigratorUtils.cpp(123) : error C2451: conditional expression of type 'nsCOMPtr' is illegal

Comment 21

2 years ago
The problem with the migration source is tracked in bug 1181895:

https://bugzilla.mozilla.org/show_bug.cgi?id=1181895
(Assignee)

Comment 22

2 years ago
Comment on attachment 8631492 [details] [diff] [review]
package-manifest.in change for im/ (v1)

Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/a22d99bf93b7
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 44.0
Duplicate of this bug: 1179904
You need to log in before you can comment on or make changes to this bug.