App updates are blocked when "update.2g.enabled": false and device is in 2G (when only OTA updates should be blocked)

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: brg, Assigned: Carmen Jimenez Cabezas)

Tracking

unspecified
FxOS-S3 (24Jul)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 verified, b2g-v2.1S verified, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Scenario of testing:
- Testing v2.1 today with Flame:Gecko-2fa8eb5.Gaia-d13826b
- "update.2g.enabled": false (default value) 
- device is camped in 2G/GPRS/EDGE.

Device received a notification of a new version of Marketplace applications and the upgrade is not possible to be downloaded until device moves to 3G or Wifi.

We had not tested it yet but we suspect that this behaviour will impact any other update of third app in the device.

EXPECTED behaviour:
Only OTA or FOTA (big system updates) should be blocked in this scenario. The update of third party applications should avoid the restriction.

More information:
- By modifying:"update.2g.enabled": true in B2G/gaia/build/config/custom-settings.json
- then the update of the Marketplace is properly download when device is camped in 2G.
Just adding that the functionality "[FOTA]Not allow updates via 2G" was implemented in bug 1039509
status-b2g-v2.1: --- → affected
See Also: → bug 1039509
(Reporter)

Comment 2

3 years ago
Testing master, with user builds, the behaviour is the same as the one described in v2.1.
(Assignee)

Updated

3 years ago
Assignee: nobody → carmen.jimenezcabezas
Created attachment 8632485 [details] [review]
[gaia] mcjimenez:bug1182035_v2_1 > mozilla-b2g:v2.1
Created attachment 8632495 [details] [review]
[gaia] mcjimenez:bug1182035 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8632495 - Flags: review?(apastor)
Comment on attachment 8632495 [details] [review]
[gaia] mcjimenez:bug1182035 > mozilla-b2g:master

r=me adding a unit test to cover this. Thanks!
Attachment #8632495 - Flags: review?(apastor) → review+
(Assignee)

Comment 6

3 years ago
Comment on attachment 8632495 [details] [review]
[gaia] mcjimenez:bug1182035 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Users won't be able to install app updates over 2G when the build is configured to forbid *system* updates over 2G.
[Testing completed]: Manual and unit tests
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: None
Attachment #8632495 - Flags: approval-gaia-v2.1?
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/2b84c3273056fe0134d21033396c614405ab0f64

If you intend to land this on v2.1, you should be also requesting v2.2 uplift at the same time (unless it's unaffected for some reason).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S3 (24Jul)
(Assignee)

Comment 8

3 years ago
Comment on attachment 8632495 [details] [review]
[gaia] mcjimenez:bug1182035 > mozilla-b2g:master

Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Users won't be able to install app updates over 2G when the build is configured to forbid *system* updates over 2G.
[Testing completed]: Manual and unit tests
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: None
Attachment #8632495 - Flags: approval-gaia-v2.2?
Created attachment 8633966 [details] [review]
[gaia] mcjimenez:bug1182035_v2_2 > mozilla-b2g:v2.2

Comment 10

3 years ago
Hi Vance,
Do we still need this for 2.1/2.1S?
Thanks!
Flags: needinfo?(vchen)

Comment 11

3 years ago
Comment on attachment 8632495 [details] [review]
[gaia] mcjimenez:bug1182035 > mozilla-b2g:master

Approving for 2.2 as this cause function broken.
Attachment #8632495 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Reporter)

Comment 12

3 years ago
(In reply to Josh Cheng [:josh] from comment #10)
> Hi Vance,
> Do we still need this for 2.1/2.1S?
> Thanks!

Vance is on PTO, only in case he cannot attend this call: We are in the certification phase for v2.1. We would like to have the fix in this branch as well. Thanks.

Comment 14

3 years ago
Comment on attachment 8632495 [details] [review]
[gaia] mcjimenez:bug1182035 > mozilla-b2g:master

Thanks Beatriz!
Attachment #8632495 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/9a1a6ab6a00646abf19f8371cd419c78783ef7f5
status-b2g-v2.1: affected → fixed
Flags: needinfo?(vchen)
status-b2g-v2.1S: --- → fixed
The v2.1s patch has a Linter error. Can you please post a follow-up patch?
https://treeherder.mozilla.org/logviewer.html#?job_id=137907&repo=mozilla-b2g34_v2_1
Flags: needinfo?(carmen.jimenezcabezas)
(Assignee)

Comment 17

3 years ago
sure
(Assignee)

Updated

3 years ago
Flags: needinfo?(carmen.jimenezcabezas)
Unit test failures as well. Reverted.
https://treeherder.mozilla.org/logviewer.html#?job_id=138051&repo=mozilla-b2g34_v2_1

v2.1: https://github.com/mozilla-b2g/gaia/commit/9dba58d18006e921546cec62c76074ce81e16518
status-b2g-v2.1: fixed → affected
status-b2g-v2.1S: fixed → affected
Flags: needinfo?(carmen.jimenezcabezas)

Comment 19

3 years ago
Created attachment 8638372 [details]
Verified_Flame_master.3gp

This bug has been verified as pass on latest build of Flame v2.2/master and Nexus5 v2.2/master by the STR in Comment 0.

Actual result: When user taps update notification of Marketplace application new version in status bar with 2G, there is a prompt, then tap download, it can download successfully.
Reproduce rate: 0/5
See Video: Verified_Flame_master.3gp

Device: Flame v2.2(Pass)
Build ID               20150723002503
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d8326043baec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150723.041700
Firmware Date          Thu Jul 23 04:17:12 EDT 2015
Firmware Version: v18D v4
Bootloader             L1TC000118D0

Device: Flame master(Pass)
Build ID               20150723160204
Gaia Revision          ec2199b324304d3678b6a98a08a31bdc13c9e984
Gaia Date              2015-07-23 17:16:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cb8bdb8ffaef
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150723.193607
Firmware Date          Thu Jul 23 19:36:19 EDT 2015
Firmware Version: v18D v4
Bootloader             L1TC000118D0

Device: Nexus5 v2.2(Pass)
Build ID               20150723002503
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d8326043baec
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150723.042111
Firmware Date          Thu Jul 23 04:21:29 EDT 2015
Bootloader             HHZ12f

Device: Nexus5 master(Pass)
Build ID               20150723160204
Gaia Revision          ec2199b324304d3678b6a98a08a31bdc13c9e984
Gaia Date              2015-07-23 17:16:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cb8bdb8ffaef
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150723.193419
Firmware Date          Thu Jul 23 19:34:37 EDT 2015
Bootloader             HHZ12f

Updated

3 years ago
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified

Updated

3 years ago
QA Whiteboard: [MGSEI-Triage+]
Created attachment 8638472 [details] [review]
[gaia] mcjimenez:bug1182035_v2_1_withTest > mozilla-b2g:v2.1
(Assignee)

Comment 21

3 years ago
Fixed the unit tests and the linter problem, sorry about that. Can you merge the PR again, Ryan?
Flags: needinfo?(carmen.jimenezcabezas) → needinfo?(ryanvm)
(Assignee)

Updated

3 years ago
Attachment #8632485 - Attachment is obsolete: true
v2.1: https://github.com/mozilla-b2g/gaia/commit/f379a0c8e521eef9fec227568cdb22d48604bc5a
status-b2g-v2.1: affected → fixed
status-b2g-v2.1S: affected → fixed
Flags: needinfo?(ryanvm)
(Reporter)

Comment 23

3 years ago
Tested today using Flame build in v2.1 Gecko-8d3d30b and Gaia-f379a0c, the app update is downloaded when the device is camped in 2G.
Thanks to everyone for fixing this.

Comment 24

3 years ago
Created attachment 8640315 [details]
Verified video:dophin_512(2.1s).3gp


The bug has been verified as pass on latest build of 2.1S(512MB) by the STR in Comment 0.
Actual results: The app update is downloaded when the device is camped in 2G.

See attachment: 2.1s.3gp
Reproduce rate :0/5
Device: v2.1s_512MB(Pass):
Build ID               20150728001205
Gaia Revision          2ac3b9d517edaa2db66d6a8fe455855ae7f675d3
Gaia Date              2015-07-28 00:09:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/d03574a86b4c
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  145
Firmware Date          Thu Apr 16 22:58:57 CST 2015

Per Comment 23, change the status of 2.1 to 'verified'.

Updated

3 years ago
status-b2g-v2.1: fixed → verified
status-b2g-v2.1S: fixed → verified

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.