display download dialog first instead of downloading the file

VERIFIED INCOMPLETE

Status

()

Firefox
PDF Viewer
VERIFIED INCOMPLETE
2 years ago
a year ago

People

(Reporter: kernp25, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-f-needinfo])

(Reporter)

Description

2 years ago
1.) Open this pdf (100 MB) with the built-in pdf viewer (pdf.js):
http://www.cartographicperspectives.org/index.php/journal/article/download/cp43-complete-issue/577
2.) Click the download button to download file
3.) Wait...

It looks like, it downloads the file first and then displays the download dialog.
I think this is bad behavior because, what if the user clicks the cancel button later (when the dialog will finally display) on the dialog? Then the download will be a waste.

It should work like "Save Page As..." (the dialog will display instantly without download the file)
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1182050
When I click the link above I am prompted right away to save the file first. It doesn't launch PDF.js. How are you able to get pdf.js to first load the file?
Flags: needinfo?(kernp25)
Whiteboard: [pdfjs-f-needinfo]
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(kernp25)
Resolution: --- → INCOMPLETE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.