Closed Bug 1182055 Opened 9 years ago Closed 9 years ago

[Linux] Context not displayed via Chromium

Categories

(Hello (Loop) :: Client, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: adalucinet, Unassigned)

References

Details

(Whiteboard: [investigation])

Reproducible with latest 41.0a2 and 42.0a1 (from 2015-07-08)
Affected platforms: Ubuntu 12.04 and 14.04, both 32-bit

Steps to reproduce:

1. Start Firefox
2. Tick 'Let's Talk about' and start a conversation
3. Join the conversation on another browser/PC

Expected results: C

Actual results:

Additional notes:
1. Screenshot: http://i.imgur.com/zJwxePc.jpg 
2. The chat area is misplaced, but after entering some words it gets in the right place: http://i.imgur.com/uPvloSQ.jpg. Should I file a separate issue on this matter?
2. Not reproducible under Windows 7 64-bit, Windows 10 64-bit nor Mac OS X 10.9.5
Adding the missing Expected/Actual results (sorry for the noise):

Expected results: Context is displayed.
Actual results: Context is not displayed. Chat area is misplaced.
Depends on: 1182070
Alexandra, could you try this with the web console open and see if there's any messages displayed when you load the page?

Also, if you're able to test on 64-bit, that might be interesting as well.
Flags: needinfo?(alexandra.lucinet)
(In reply to Mark Banner (:standard8) from comment #2)
> Alexandra, could you try this with the web console open and see if there's
> any messages displayed when you load the page?
> 
> Also, if you're able to test on 64-bit, that might be interesting as well.

Also reproducible under Ubuntu 13.10 64-bit with Chrome - please see below screenshots with the console's output for both latest 42.0a1 and Chrome:
*Browser console: http://i.imgur.com/3Kurpmi.jpg
*Web console: http://i.imgur.com/mXmkWkp.jpg
Flags: needinfo?(alexandra.lucinet)
Thanks for testing. I don't know what's happening here. I can't reproduce this at all (I used ubuntu 15.10).

The message on the console implies that there's no context data stored with the room - but opening the rooms you created clearly shows that it is present. There's no errors logged on the server, so I don't see what is going on.

One other thought: On Chrome's web console, go to the network tab before loading the page.

In the list, near the bottom, there should be an item with type = "xhr" and the name being the room token (the bit of the url before the #). If you click on that, it should show the result - is there a context item listed there?
(In reply to Mark Banner (:standard8) from comment #4)
> One other thought: On Chrome's web console, go to the network tab before
> loading the page.
> 
> In the list, near the bottom, there should be an item with type = "xhr" and
> the name being the room token (the bit of the url before the #). If you
> click on that, it should show the result - is there a context item listed
> there?

I did not see any item in Chrome's web console with Type = xhr, but I did get this - http://i.imgur.com/eee1Gq9.png which also has a context item. Hopefully this is what you asked for; if not, more details will be very helpful :)
Rank: 36
Priority: -- → P3
Whiteboard: [context] → [context, investigation]
Whiteboard: [context, investigation] → [investigation][triage]
Whiteboard: [investigation][triage] → [investigation]
Alexandra, can you retest this with the latest code, but on a ubuntu older than 15.1 and with 15.1 ?

I'm wondering if there's an issue with the older ubuntu versions.
Flags: needinfo?(alexandra.lucinet)
Tested with latest Nightly 47.0a1 2016-02-07 under Ubuntu 15.04 x64 and Ubuntu 14.04 x32: the issue no longer occurs.

I'm not changing the resolution yet as Alexandra may want to check on the machine where it first reproduced.
Flags: needinfo?(alexandra.lucinet)
Confirming the same behaviour as Petruta stated - this issue is no longer reproducible with latest Nightly 47.0a1 (from 2016-02-08), under Ubuntu 14.04 32-bit (2 different machines). Marking accordingly.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.