Panorama accidental drag causes tab to move to end of group

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: bugzilla.mozilla.org, Unassigned)

Tracking

Trunk

Details

(Reporter)

Description

3 years ago
When attempting to open the top-most tab of a collapsed group in panorama while the mouse is not completely at rest this can be interpreted as a drag and drop over a short distance.

This results the tab from being removed from its group and immediately added back at the end of the same group.

This has multiple negative consequences:

- action intended to open tab does not open it
- tab loses its position in the group
- original position cannot be restored since there is no way to sort, see bug 1179921



Suggested solution: suppress drops unless the target is outside the current group and reinterpret them as clicks.

This would also make the panorama UI more pen-tablet friendly, hover-clicking with a pen can be quite jittery.

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.