Mozilla 0.9.7 crashes in NSGetModule->PL_DHashTableOperate

RESOLVED WORKSFORME

Status

()

Core
Networking: Cache
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Greg Steuck, Assigned: gordon)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Once in a blue moon the lizard goes down with this stack trace:
(gdb) where
#0  0x00000011 in ?? ()
#1  0x400fe4ec in PL_DHashTableOperate ()
   from /usr/local/mozilla-0.9.7/libxpcom.so
#2  0x411992df in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnkcache.so
#3  0x411a29b0 in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnkcache.so
#4  0x4119d9f9 in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnkcache.so
#5  0x4119d8d3 in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnkcache.so
#6  0x41199d84 in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnkcache.so
#7  0x411996ed in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnkcache.so
#8  0x41199561 in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnkcache.so
#9  0x40173d5f in nsCOMPtr_base::assign_with_AddRef ()
   from /usr/local/mozilla-0.9.7/libxpcom.so
#10 0x409265ee in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnecko.so
#11 0x40925176 in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnecko.so
---Type <return> to continue, or q <return> to quit---
#12 0x4092a9dc in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnecko.so
#13 0x4093dee4 in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnecko.so
#14 0x408ed0e4 in NSGetModule ()
   from /usr/local/mozilla-0.9.7/components/libnecko.so
#15 0x4013f907 in PL_HandleEvent () from /usr/local/mozilla-0.9.7/libxpcom.so
#16 0x4013f823 in PL_ProcessPendingEvents ()
   from /usr/local/mozilla-0.9.7/libxpcom.so
#17 0x40140758 in nsEventQueueImpl::ProcessPendingEvents ()
   from /usr/local/mozilla-0.9.7/libxpcom.so
#18 0x40806133 in _fini ()
   from /usr/local/mozilla-0.9.7/components/libwidget_gtk.so
#19 0x40805ead in _fini ()
   from /usr/local/mozilla-0.9.7/components/libwidget_gtk.so
#20 0x4037f01e in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#21 0x403807f3 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#22 0x40380dd9 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#23 0x40380f8c in g_main_run () from /usr/lib/libglib-1.2.so.0
#24 0x40294803 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#25 0x408065c4 in _fini ()
   from /usr/local/mozilla-0.9.7/components/libwidget_gtk.so
#26 0x406cd35e in NSGetModule ()
---Type <return> to continue, or q <return> to quit---
   from /usr/local/mozilla-0.9.7/components/libnsappshell.so
#27 0x0804f709 in main1 ()
#28 0x0804ff77 in main ()
#29 0x404c9306 in __libc_start_main (main=0x804fe48 <main>, argc=1, 
    ubp_av=0xbffff7a4, init=0x804b550 <_init>, fini=0x8050cc8 <_fini>, 
    rtld_fini=0x4000d2dc <_dl_fini>, stack_end=0xbffff79c)
    at ../sysdeps/generic/libc-start.c:129
Reporter: 
We need a stack trace with symbols (your stack is from an optimized build) and
steps to reproducve the problem.
Can you please use a talkback enabled build and add the talkback ID in this bug ?

We have talkback for random crashes.(Search bugzilla with the keyword: topcrash)
If you can reproduce a crash, file a bug (if possible with talkback ID).

Comment 2

16 years ago
This may be a duplicate of bug 114292.

I have seen this bug in an RPM of mozilla-0.9.7 that was built
from the Red Hat 7.2 SRPM.  However, the RPM was built and
installed on my Red Hat 6.2 box.

I've had two similar stack traces occur while mozilla-0.9.7 was
running under gdb (after at least two similar lock-ups without
gdb).

I will try to rebuild mozilla-0.9.7 RPMs with debug symbols
and/or Talkback (if that support can be built-in locally), and
report a full stack trace when I get one.

Comment 3

16 years ago
Stack trace #1:

Program received signal SIGSEGV, Segmentation fault.
0x6f0079 in ?? ()
(gdb) where
#0  0x6f0079 in ?? ()
#1  0x4010458c in PL_DHashTableOperate () from /usr/lib/libxpcom.so
#2  0x40f1761f in ?? ()
#3  0x40f20cf0 in ?? ()
#4  0x40f1bd39 in ?? ()
#5  0x40f1bc13 in ?? ()
#6  0x40f180c4 in ?? ()
#7  0x40f17a2d in ?? ()
#8  0x40f178a1 in ?? ()
#9  0x40179e1f in nsCOMPtr_base::assign_with_AddRef ()
   from /usr/lib/libxpcom.so
#10 0x4075cc2e in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#11 0x4075b7b6 in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#12 0x4076101c in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#13 0x40774514 in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#14 0x40723724 in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#15 0x401459c7 in PL_HandleEvent () from /usr/lib/libxpcom.so
#16 0x401458e3 in PL_ProcessPendingEvents () from /usr/lib/libxpcom.so
#17 0x40146818 in nsEventQueueImpl::ProcessPendingEvents ()
   from /usr/lib/libxpcom.so
#18 0x406497a3 in NSGetModule ()
   from /usr/lib/mozilla/components/libwidget_gtk.so
#19 0x4064951d in NSGetModule ()
   from /usr/lib/mozilla/components/libwidget_gtk.so
#20 0x4035eaca in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#21 0x40360186 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#22 0x40360751 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#23 0x403608f1 in g_main_run () from /usr/lib/libglib-1.2.so.0
#24 0x402848e9 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#25 0x40649c34 in NSGetModule ()
   from /usr/lib/mozilla/components/libwidget_gtk.so
#26 0x4062a8ce in NSGetModule ()
   from /usr/lib/mozilla/components/libnsappshell.so
#27 0x804f729 in NS_CreateNativeAppSupport ()
#28 0x804ff97 in main ()
#29 0x404619cb in __libc_start_main (main=0x804fe68 <main>, argc=1, 
    argv=0xbffff9d4, init=0x804b570 <_init>, fini=0x8050ce8 <_fini>, 
    rtld_fini=0x4000ae60 <_dl_fini>, stack_end=0xbffff9cc)
    at ../sysdeps/generic/libc-start.c:92
(gdb) 

Comment 4

16 years ago
Stack trace #2:

Program received signal SIGSEGV, Segmentation fault.
0x1 in ?? ()
(gdb) where
#0  0x1 in ?? ()
#1  0x4010458c in PL_DHashTableOperate () from /usr/lib/libxpcom.so
#2  0x40f1761f in ?? ()
#3  0x40f20cf0 in ?? ()
#4  0x40f1bd39 in ?? ()
#5  0x40f1bc13 in ?? ()
#6  0x40f180c4 in ?? ()
#7  0x40f17a2d in ?? ()
#8  0x40f178a1 in ?? ()
#9  0x40179e1f in nsCOMPtr_base::assign_with_AddRef ()
   from /usr/lib/libxpcom.so
#10 0x4075cc2e in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#11 0x4075b7b6 in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#12 0x4076101c in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#13 0x40774514 in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#14 0x40723724 in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#15 0x401459c7 in PL_HandleEvent () from /usr/lib/libxpcom.so
#16 0x401458e3 in PL_ProcessPendingEvents () from /usr/lib/libxpcom.so
#17 0x40146818 in nsEventQueueImpl::ProcessPendingEvents ()
   from /usr/lib/libxpcom.so
#18 0x406497a3 in NSGetModule ()
   from /usr/lib/mozilla/components/libwidget_gtk.so
#19 0x4064951d in NSGetModule ()
   from /usr/lib/mozilla/components/libwidget_gtk.so
#20 0x4035eaca in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#21 0x40360186 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#22 0x40360751 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#23 0x403608f1 in g_main_run () from /usr/lib/libglib-1.2.so.0
#24 0x402848e9 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#25 0x40649c34 in NSGetModule ()
   from /usr/lib/mozilla/components/libwidget_gtk.so
#26 0x4062a8ce in NSGetModule ()
   from /usr/lib/mozilla/components/libnsappshell.so
#27 0x804f729 in NS_CreateNativeAppSupport ()
#28 0x804ff97 in main ()
#29 0x404619cb in __libc_start_main (main=0x804fe68 <main>, argc=1, 
    argv=0xbffff9d4, init=0x804b570 <_init>, fini=0x8050ce8 <_fini>, 
    rtld_fini=0x4000ae60 <_dl_fini>, stack_end=0xbffff9cc)
    at ../sysdeps/generic/libc-start.c:92
(gdb) 

Comment 5

16 years ago
Hmm...one major difference in this version from 0.9.6 (other than
the fact that I compiled it myself) was that I installed the
Java 2 plugin from ftp.netscape.com with 0.9.7.  I wonder if this
would make a difference.

Comment 6

16 years ago
I haven't instaled Java, so it is not likely to be a factor.
You can install talkback from here (to get a stack with symbols):
http://ftp.mozilla.org/pub/mozilla/releases/mozilla0.9.7/linux-xpi/talkback.xpi

(you must have Software installation enabled)

Comment 8

16 years ago
I got several crashes, maybe same problem:
- rpm self compiled from srpm for RH7.2
- RH6.2 + all updates + kernel 2.4.17
- egcs-1.1.2-30
- binutils-2.10.91.0.2-3
- Ximian Gnome 1.4

PS: I can't install the talkback.xpi via Software install even if it's enabled..
it never starts the download from http://ftp.mozilla.org/.....
I downloaded talkback.xpi and I'd like to install it manually... how do I do it ?

Comment 9

16 years ago
severity:critical
I can reliably reproduce this using 2002011021 bits -> Mozilla crashes on me
everytime I visit above website.
Optimized stack trace looks the same as in original description (differs
slightly from call #25 onwards).
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 10

16 years ago
I believe this was fixed mid/late January.  Can you please try it with a more
recent build?

Comment 11

16 years ago
you're right, it's fixed. 2002030621 displays the site just fine.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.