Closed Bug 1182079 Opened 4 years ago Closed 4 years ago

Intermitten test_ui-showcase.py TestDesktopUnits.test_units | TimeoutException: TimeoutException: Error loading page, timed out (checkLoad)

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
Points:
1

Tracking

(firefox40 unaffected, firefox41 fixed, firefox42 fixed, firefox-esr38 unaffected)

RESOLVED FIXED
mozilla42
Iteration:
42.3 - Aug 10
Tracking Status
firefox40 --- unaffected
firefox41 --- fixed
firefox42 --- fixed
firefox-esr38 --- unaffected

People

(Reporter: cbook, Assigned: standard8)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=3694928&repo=fx-team

05:45:27 ERROR - TEST-UNEXPECTED-ERROR | test_ui-showcase.py TestDesktopUnits.test_units | TimeoutException: TimeoutException: Error loading page, timed out (checkLoad)
05:45:27 INFO - Traceback (most recent call last):
05:45:27 INFO - File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette_test.py", line 296, in run
05:45:27 INFO - testMethod()
05:45:27 INFO - File "/builds/slave/test/build/tests/marionette/tests/browser/components/loop/test/ui-showcase/test_ui-showcase.py", line 16, in test_units
05:45:27 INFO - self.check_page("index.html")
05:45:27 INFO - File "/builds/slave/test/build/tests/marionette/tests/browser/components/loop/test/shared/frontend_tester.py", line 97, in check_page
05:45:27 INFO - self.marionette.navigate(urlparse.urljoin(self.server_prefix, page))
05:45:27 INFO - File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 1335, in navigate
05:45:27 INFO - return self._send_message("get", "ok", url=url)
05:45:27 INFO - File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette_driver/decorators.py", line 36, in _
05:45:27 INFO - return func(*args, **kwargs)
05:45:27 INFO - File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 715, in _send_message
05:45:27 INFO - self._handle_error(response)
05:45:27 INFO - File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 751, in _handle_error
05:45:27 INFO - raise errors.lookup(status)(message, stacktrace=stacktrace)
05:45:27 INFO - TEST-INFO took 33866ms
05:45:28 INFO - SUMMARY
This is approaching permafail level. Needs attention now or a disabling if that's not possible.
Flags: needinfo?(standard8)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #111)
> This is approaching permafail level. Needs attention now or a disabling if
> that's not possible.

If they're Loop related, it'd be nice to cc us earlier. However, I totally get not everyone realises that. I'll see if I can get improving error messages back on our schedule again.

For this issue, I have an idea, I can't quickly find the bit of code at the moment, and I'm just about to sign-off for the night, but I'll take a look in the morning and get a try build running.
Flags: needinfo?(standard8)
This fixes the issue on try afaict, so lets get it out there. I've included a potential improvement for bug 1142970 as well. Basically debug builds seem to be just slow, and the size of our files are getting big.

I don't think we're ready to split them up yet as we're still discussing about what we want to do, especially for the ui-showcase.

I'll take review from whoever gets there first.
Attachment #8644901 - Flags: review?(dmose)
Attachment #8644901 - Flags: review?(dburns)
Attachment #8644901 - Flags: review?(andrei.br92)
Assignee: nobody → standard8
Iteration: --- → 42.3 - Aug 10
Points: --- → 1
Component: Marionette → Client
Product: Testing → Hello (Loop)
Blocks: 1142970
Comment on attachment 8644901 [details] [diff] [review]
Fix intermittent test failure loading the Loop's ui-showcase on debug builds by extending the page load timeout, and improve the failure naming.

Review of attachment 8644901 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good for me but based on what Ed was saying about how slow debug unoptimized builds run, doubling the timeout still might not be enough.
Attachment #8644901 - Flags: review?(andrei.br92) → review+
Attachment #8644901 - Flags: review?(dmose)
Attachment #8644901 - Flags: review?(dburns)
(In reply to Andrei Oprea [:andreio] from comment #152)
> This looks good for me but based on what Ed was saying about how slow debug
> unoptimized builds run, doubling the timeout still might not be enough.

Yeah we'll see. Ed's issues were slightly different though I believe.

Tree's closed so adding checkin-needed, try run in comment 145.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d907c75bca6a
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
As far as I can tell from a quick skim of brasstacks, all the errors highlighted by the robot are related to a different MSE marionette test, not the test that this bug is about.  So it looks to me like the OrangeFactor robot needs some adjustment.  Adding a needinfo to RyanVM, as I'm unsure about the next step to cause that to happen...
Flags: needinfo?(ryanvm)
Restrict Comments: true
Restrict Comments: false
Redirecting to an active sheriff to answer that :)
Flags: needinfo?(ryanvm) → needinfo?(cbook)
(In reply to Dan Mosedale (:dmose) - use needinfo flag for response from comment #164)
> As far as I can tell from a quick skim of brasstacks, all the errors
> highlighted by the robot are related to a different MSE marionette test, not
> the test that this bug is about.  So it looks to me like the OrangeFactor
> robot needs some adjustment.  Adding a needinfo to RyanVM, as I'm unsure
> about the next step to cause that to happen...

seems this were miss-stars Dan, sorry for that also seems it didn't happened after that first ones
Flags: needinfo?(cbook)
You need to log in before you can comment on or make changes to this bug.