Dragging URL icon on nonworking bookmark makes mozilla unusable

VERIFIED DUPLICATE of bug 96504

Status

()

Core
Drag and Drop
--
critical
VERIFIED DUPLICATE of bug 96504
17 years ago
17 years ago

People

(Reporter: Arthur, Assigned: Blake Ross)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.7+) Gecko/20020104
BuildID:    2002010408

If you drag a link icon into the bookmark menu on the personal toolbar and
further on a nonworking (or outdated) link, the bookmark menu will stay open and
a error dialog opens *below* the bookmark menu, making it impossible to dismiss
the errror dialog. You can't even exit mozilla.


Reproducible: Always
Steps to Reproduce:
0.Save all your open files and mails :)
1.Make a invalid bookmark entry like file:///thisfiledoesntexist.none
2.Go to a web page like http://www.mozilla.org/
3.Drag the lizards head (favicon) to the personal toolbar bookmark folder.
4.Drag it to the invalid bookmark and releas it above it.
5.Have fun.

Actual Results:  I'm not able to close the menu or the error dialog, in fact, I
can't do anything else than terminating mozilla, at least kill -9 isn't necessary.

Expected Results:  Place the new bookmark above or below the outdated one.

I've found quite a few bookmark/drag&drop bugs, but none really seems to be the
same. But then, I've never been to good in searching bugzilla...

Comment 1

17 years ago
Isn't this just a special case of the bug 96504 ? (i.e. similar things happen
with working bookmarks too.)
(Reporter)

Comment 2

17 years ago
You're right. I've told you I'm no good at searching with bugzilla :)

*** This bug has been marked as a duplicate of 96504 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.