Last Comment Bug 1182214 - [AccessFu][Android] update system highlight on scroll or viewport changes
: [AccessFu][Android] update system highlight on scroll or viewport changes
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: ARM Android
-- normal (vote)
: mozilla43
Assigned To: Eitan Isaacson [:eeejay]
:
: alexander :surkov
Mentors:
Depends on:
Blocks: AndroidA11yUpdates
  Show dependency treegraph
 
Reported: 2015-07-09 11:34 PDT by Yura Zenevich [:yzen]
Modified: 2015-09-14 17:15 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Update highlight rect as you scroll. (7.18 KB, patch)
2015-09-10 13:50 PDT, Eitan Isaacson [:eeejay]
yzenevich: review+
Details | Diff | Splinter Review
Follow-up to fix Presentation.displayedAccessibles getter. (1017 bytes, patch)
2015-09-14 13:30 PDT, Eitan Isaacson [:eeejay]
eitan: review+
Details | Diff | Splinter Review

Description User image Yura Zenevich [:yzen] 2015-07-09 11:34:35 PDT
Right now on when we scroll (or change orientation) our highlight changes but the voice over one is not updated until the next navigation. Ideally we want to be in sync (and since we are removing our outline, this should just work).
Comment 1 User image Eitan Isaacson [:eeejay] 2015-09-10 13:50:23 PDT
Created attachment 8659478 [details] [diff] [review]
Update highlight rect as you scroll.
Comment 2 User image Yura Zenevich [:yzen] 2015-09-11 11:11:48 PDT
Comment on attachment 8659478 [details] [diff] [review]
Update highlight rect as you scroll.

Review of attachment 8659478 [details] [diff] [review]:
-----------------------------------------------------------------

looks nice
Comment 4 User image Eitan Isaacson [:eeejay] 2015-09-14 13:30:22 PDT
Created attachment 8660916 [details] [diff] [review]
Follow-up to fix Presentation.displayedAccessibles getter.

Note You need to log in before you can comment on or make changes to this bug.