IP Address conflict in IRC

RESOLVED FIXED

Status

Infrastructure & Operations
Infrastructure: IRC
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: santosh, Assigned: lerxst)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

We want to use #marketplaceday channel for our event. Since we are connected through the same network all are unable to use a channel at the same time.



Actual results:

We get an error when everyone trying to access a channel from the same network.


Expected results:

We want access to the IRC Channel so that all the attendees will be able to access the same channel from the same network.
(Reporter)

Comment 1

2 years ago
Hey amy,

  Can you help us with this.We want to use #marketplaceday channel for our marketplace day and we want it to be open.

Thanks,
Flags: needinfo?(atsay)

Updated

2 years ago
Assignee: rginda → infra
Component: ChatZilla → Infrastructure: IRC
Product: Other Applications → Infrastructure & Operations
QA Contact: dparsons
Version: unspecified → other
Hi,

I am asking more information.

Can you please update the bug with the IP or IP range you're all on ASAP?

Thank you.

(I am watching the cZ component and guys in #moc helpfully pointed me to the correct components to file this bug in, and what information to request.)
Flags: needinfo?(viswanathamsantosh)
(Assignee)

Comment 3

2 years ago
Get someone at the event with valid LDAP credentials to go to https://iplimit.irc.mozilla.org/ be sure to connect from the same IP address that is being blocked. This should fix your problem.
(Assignee)

Updated

2 years ago
Assignee: infra → dparsons
(Reporter)

Comment 4

2 years ago
Hey,

  our IP address is 49.204.51.207  We will be around 50+ users who will try to access the same channel.

Thanks.
Flags: needinfo?(viswanathamsantosh) → needinfo?(svetlana)
Do we have a person at the event (one of organizers) who can do the thing mentioned in comment 3 above?
Flags: needinfo?(svetlana)
(Assignee)

Comment 6

2 years ago
Now that I have an actual IP address, I was able to add the exception manually. The tool mentioned in comment 3 would also have worked, so feel free to keep it in mind for the future.

The exception is added and will take effect within the next 30 minutes or so.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(atsay)
Resolution: --- → FIXED
Right now only 3 people are joined in the channel #marketplaceday and when someone else want to connect, we are getting following error -

Closing link: (Mibbit@49.204.42.83) [Too many connections from your IP  (local class). If you have a Mozilla LDAP account, you can get a  temporary exemption here: https://iplimit.irc.mozilla.org/].

Please check this.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
It looks like this is because of dynamic IP Address. The new IP address is 49.204.42.83

Comment 9

2 years ago
I've added the new IP and :ramd verified it works.


# bug 1182221, delete by 8/2015
<connect parent="main" allow="49.204.42.83" localmax="100" globalmax="100" limit="101" modes="+x">
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
>> "You are banned from the channel #marketplaceday"

We are now getting above error if someone leave and join again. We have not even reached limit (we are just 10-15 people there on this channel).

We will have this event again on Aug 1st, so I just want to make sure these issues do not occur at least in that event.

Thanks,
Ram
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

2 years ago
This channel isn't in use and isn't registered in chanserv, and I'm unable to see any problems with it. Did you have a weird channel mode set while you were testing? Also, if people are having trouble accessing the channel during the event, have someone with a valid Mozilla LDAP login go to this URL, from the internet connection at the event, and it will create an exception to allow more people to connect to the IRC network: https://iplimit.irc.mozilla.org/
What's the status here ?
Closing this bug for now. Will reopen if we require any assistance in any upcoming events.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
removed from conf in 109935.
You need to log in before you can comment on or make changes to this bug.