[e10s] ownCloud News app's "subscribe" buttons don't work

RESOLVED DUPLICATE of bug 1175056

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1175056
3 years ago
3 years ago

People

(Reporter: strugee, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
STR:

1. Install ownCloud[1] (I'm betting that this is also reproducible on a public ownCloud instance, but I haven't tried.)
2. Install the ownCloud News app
3. Open the News app; you should be in the "Explore" tab on the left
4. Click any of the "subscribe" buttons

At this point, nothing happens if you're in an e10s browser, but opening a non-e10s window and repeating the fourth step opens the "add subscription" UI on the left.

I'm on a Nightly built 7/9/15 running on Debian Sid. My server runs ownCloud 8.1.0 and News 5.3.8. I didn't bother to test in Safe Mode, since this seems like it's pretty obviously a platform e10s bug of some kind, but I can if needed.
(Reporter)

Comment 1

3 years ago
[1]: https://owncloud.org/
Blocks: 516752
(Reporter)

Comment 2

3 years ago
Wrong title. Apologies for the bugspam :/
Summary: [e10s] Infobar prompt to add an RSS feed doesn't show → [e10s] ownCloud News app's "subscribe" buttons don't work

Comment 3

3 years ago
Is it a dupe of bug 1175056? Could you check if you see same error in the browser console.
Flags: needinfo?(alex)
Version: unspecified → 42 Branch
(Reporter)

Comment 4

3 years ago
I get a similar error:

> 14:02:51.365 NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "aBrowserWindow.gBrowser is undefined" {file: "jar:file:///usr/local/lib/firefox-nightly/browser/omni.ja!/components/WebContentConverter.js" line: 519}]'[JavaScript Error: "aBrowserWindow.gBrowser is undefined" {file: "jar:file:///usr/local/lib/firefox-nightly/browser/omni.ja!/components/WebContentConverter.js" line: 519}]' when calling method: [nsIWebContentHandlerRegistrar::registerContentHandler]1 app.min.js:1:0

But not exactly the same.
Flags: needinfo?(alex)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1175056
You need to log in before you can comment on or make changes to this bug.