[Aries] Landscape apps appear as Portrait briefly after entering call.

RESOLVED DUPLICATE of bug 874181

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 874181
3 years ago
3 years ago

People

(Reporter: Johnt, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8631860 [details]
logcat_20150709_1449.txt

Description:
If the user ends a call while previously in landscaped app (Such as Swooop or Cut the Rope) the landscaped app will appear as portrait for a moment before transitioning back to landscape.


Repro Steps:
1) Update an Aries to 20150701145139
2) Open an app that is displayed in Landscape (Such as Swooop or Cut the Rope)
3) Receive a call from another device.
4) End call on either device.

Actual:
Landscape app appears in portrait mode for a moment.

Expected:
It is expected that the previously opened landscape app will be displayed in landscape.

Environmental Variables:
Device: Aries 2.5 
Build ID: 20150707205829
Gaia: 553e4e281d11500bea702918841f011bfb5405f7
Gecko: 0246d86e619670bf381d45d587e8ab036e7a8db5
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 10/10
See attached: Logcat & Video
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the Flame 2.5, 2.2 and 2.1.

Result: App appears in Portrait before automatically displaying to Landscape.


Environmental Variables:
Device: Flame 2.5 Kk Full flash (319mb)
Build ID: 20150709010204
Gaia: fc6643dd3da2ccdf2ab284479643836bb3698644
Gecko: f34a7120f46b
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Environmental Variables:
Device: Flame 2.2 Kk Full flash (319mb)
Build ID: 20150709002503
Gaia: d6d6a35b9407ffaf3131bc244cabc8ee2b09c4df
Gecko: e0f4a13fd1f6
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1 Kk Full flash (319mb)
Build ID: 20150709001202
Gaia: d13826b20b4a45e3f5cd4b25a30a737d8be7f1b9
Gecko: 5cfdf1a23772
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


This issue does NOT occur on Flame 2.0

Result: App returns to Landscape mode accordingly.


Environmental Variables:
Device: Flame 2.0 Kk Full flash (319mb)
Build ID: 20150709000209
Gaia: b16ba05481e577bc644ed8966f587a70fe2148e6
Gecko: 308f865c83a5
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → DUPLICATE
Duplicate of bug: 874181
You need to log in before you can comment on or make changes to this bug.