Closed Bug 1182410 Opened 4 years ago Closed 4 years ago

Pointer position is incorrect

Categories

(Firefox :: Untriaged, defect)

39 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1175863

People

(Reporter: perryrylance, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0, Build ID 20150630154324

This bug has appeared in the last update

Create a map using the Google Maps API v3, using their "Simple Marker" example. Give the map a fixed size (640x480 in my example), and then offset it's position. You can do that using a margin, border, or position: relative, or simply by adding a few lines of content.


Actual results:

- Using a 64px margin/border/top&left, the cursor changes and the "Hello World!" tooltip appears when I place the cursor at -64,-64 relative to the marker

- Using a few lines of text above the map, assuming the text is 150px in height, the cursor changes and the "Hello World!" tooltip appears when I place the cursor 0,-150 relative to the marker


Expected results:

I expect "Hello World!" tooltip to appear when I move the mouse over the marker
Broken version:

Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0



I think this is the same problem (or related) that I have just observed too since
going from v38.0.5 (no problem) to v39.0 (problem).  I use a bike 
route mapping site called bikehike ( http://bikehike.co.uk/mapview.php ) and since 
updating to v39.0 the mapping API seems to cause Firefox problems:

1. the pointer position no longer exactly matches with an OS map when working on UK maps

2. the 'Drag Edit Mode' does not work properly because the pointer/tip does not line up properly


This worked fine in v38.0.5 and earlier and still works just fine in Chrome.




Steps to reproduce:


1. goto http://bikehike.co.uk/mapview.php

2. centre on a UK address, enter  'po1 7gf' in the text box (bottom right) and click the 
'Find UK Place/Postcode' button

3. click on a road in the google map, green start point appears

4. click on another road in the main google map, a red point appears and a blue auto-routed
line should appear connecting the two points

4. click on the 'Drag Edit Mode' (it goes yellow) and then move the pointer over the map's
 blue route line, say in the middle of the route.  A little circle with finger pointer 
should appear.

5. hold down mouse button to try and drag the route, you will get the 
little clenched hand pointer but chances are the route will not drag properly since 
v39. I can only get it to intermittently work now.

You may need to compare this to the working behaviour in Chrome or Firefox v38.0.5 where it works
smoothly.

Also if you zoom in to both the google and OS map, then hover the pointer over a road junction
you will find that they no longer align. Again no problem in Chrome or Firefox v38.0.5.



Expected results:

1. the pointer should permit reliable drag/edit to work on this site

2. the pointer between the two maps should align (to within 5-10 pixels at least), it is currently
much further out
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1175863
You need to log in before you can comment on or make changes to this bug.