Closed Bug 1182533 Opened 6 years ago Closed 6 years ago

Eliminate race conditions in the ico-bmp-corrupted tests

Categories

(Core :: ImageLib, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla42
Tracking Status
firefox42 --- fixed

People

(Reporter: seth, Assigned: seth)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We've had lots of intermittent orange issues with the ico-bmp-corrupted tests, and now bug 1117607 is turning those into permaoranges. That's actually a good thing, as it makes it easier to debug them.

It turns out that the source of the problem is that our rendering is nondeterministic when an error is detected in the image data of an image (as opposed to the header).

I've filed bug 1182531 about fixing the underlying problem, but I'd rather that issue not block bug 1117607. So in this bug, we'll:

- Modify ico-bmp-corrupted/wrapper.html to sync decode the corrupt images *before* loading them into the final <img> element, which eliminates the nondeterminism.

- Annotate the ico-bmp-corrupted tests to make it clear which ones detect the error in the header and which ones detect the error in the image data. That should make it easier to fix bug 1182531 later.
Here's the patch. This eliminates the nondeterminism I was seeing in bug
1117607.
Attachment #8632182 - Flags: review?(tnikkel)
Attachment #8632182 - Flags: review?(tnikkel) → review+
https://hg.mozilla.org/mozilla-central/rev/567ba1606694
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.