[FTU] {{undefined}} appears in the text on the 'About Firefox OS' and 'Geolocation' page in FTE

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::First Time Experience
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: oliverthor, Assigned: stas)

Tracking

({regression})

unspecified
FxOS-S3 (24Jul)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing], [Spark], [systemsfe])

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8632189 [details]
logcat_20150710_1052.txt

Description:
When a user has just flashed their device, or resets their phone, and is proceeding through the First Time Experience, they will observe on the screen 'About Firefox OS' that {{undefined}} appears near the beginning of the text.

Repro Steps:
1) Update a Aries to 20150710105517
2) Progress through FTU to 'Geolocation' or 'About Firefox OS' page
3) Observe 'undefined' in text

Actual:
The text 'undefined' appears in the text on pages 'Geolocation' and 'About Firefox OS'

Expected:
No debug text appears; text displaying is 'Firefox OS'


Environmental Variables:
-------------------------

Device: Aries 2.5
Build ID: 20150710105517
Gaia: ad76c159c641c977d9140c5fedea84aea04e0e60
Gecko: f7e1f596d57d
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.5
BuildID: 20150710010203
Gaia: ad76c159c641c977d9140c5fedea84aea04e0e60
Gecko: 2c91d57441fd
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
**************************

Issue DOES NOT REPRODUCE on 2.2 for flame devices
Results: No debug text appears; text displaying is 'Firefox OS'

Device: Flame 2.2
BuildID: 20150710002505
Gaia: 84d0c76370dcd3d25813b00de55194730884355b
Gecko: e002005dc994
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
-------------------------


Repro frequency: 5/5
See attached: 
screenshot 
logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8632190 [details]
ftu_actual_undefined_expected_firefoxos.png
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Updated

3 years ago
Summary: [FTU] {{undefined}} appears in the text on the 'About Firefox OS' page in FTE → [FTU] {{undefined}} appears in the text on the 'About Firefox OS' and 'Geolocation' page in FTE
[Blocking Requested - why for this release]:
Visible regression of a core app (FTU).

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: pcheng
See Also: → bug 1182621
It also happens on a new Private Tab, but I guess it's the same root cause
b2g inbound regression window:

Last Working
Device: Flame
BuildID: 20150709050822
Gaia: 20e6960417b67d6f54032c62ce462987bb86a819
Gecko: 7ccb2352847d
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Device: Flame 2.5
BuildID: 20150709054022
Gaia: bdddfe1ebb796e2bc1c048d5c4e0f97f3d06f98b
Gecko: a2870e5c46fe
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working Gaia First Broken Gecko - no repro
Gaia: 20e6960417b67d6f54032c62ce462987bb86a819
Gecko: a2870e5c46fe

Last Working Gecko First Broken Gaia - repro
Gaia: bdddfe1ebb796e2bc1c048d5c4e0f97f3d06f98b
Gecko: 7ccb2352847d

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/20e6960417b67d6f54032c62ce462987bb86a819...bdddfe1ebb796e2bc1c048d5c4e0f97f3d06f98b

Caused by changes made in Bug 1169361.
Blocks: 1169361
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Looks like we are missing the {{brandShortName}} value from all the strings in ftu.en-US.properties that use it.
Flags: needinfo?(stas)

Updated

3 years ago
Duplicate of this bug: 1182621
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Created attachment 8632377 [details] [review]
[gaia] stasm:1182568-legacy-resolver > mozilla-b2g:master
(Assignee)

Comment 8

3 years ago
Created attachment 8632378 [details] [review]
Pull request against l20n.js

Zibi, if this looks good, can you land it for me?
Assignee: nobody → stas
Status: NEW → ASSIGNED
Flags: needinfo?(stas)
Attachment #8632378 - Flags: review?(gandalf)
Comment on attachment 8632378 [details] [review]
Pull request against l20n.js

LGTM
Attachment #8632378 - Flags: review?(gandalf) → review+
blocking-b2g: 2.5? → 2.5+
status-b2g-master: affected → fixed
Target Milestone: --- → FxOS-S3 (24Jul)
This bug has been verified as "pass" on the latest nightly build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: No debug text appears on 'SIM manager'/'Geolocation'/'About Firefox OS' page.
See attachment: verified_Flame_v2.5.png
Reproduce rate: 0/6


Device: Flame KK 2.5 (Pass)
Build ID               20150802150204
Gaia Revision          2ca27bbdd84526c6a3b198d9cf10f2caff1dadde
Gaia Date              2015-07-31 08:23:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/32712cd01159
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150802.183402
Firmware Date          Sun Aug  2 18:34:15 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20150801110932
Gaia Revision          2ca27bbdd84526c6a3b198d9cf10f2caff1dadde
Gaia Date              2015-07-31 08:23:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/32712cd01159
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150801.105449
Firmware Date          Sat Aug  1 10:54:56 UTC 2015
Bootloader             s1
status-b2g-master: fixed → verified
Status: RESOLVED → VERIFIED
Created attachment 8642282 [details]
verified_Flame_v2.5.png
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.