Startup crash in OOM | large | NS_ABORT_OOM(unsigned int) | nsTArray_base<T>::EnsureCapacity<T>(unsigned int, unsigned int) | nsTArray_base<T>::InsertSlotsAt<T>(unsigned int, unsigned int, unsigned int, unsigned int)

RESOLVED FIXED in Firefox 41

Status

()

Toolkit
Safe Browsing
--
critical
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: dmajor, Assigned: gcp)

Tracking

({crash})

unspecified
mozilla42
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(firefox40 unaffected, firefox41+ fixed, firefox42 fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-9415dc1b-fe9f-49e0-ade0-7adcb2150708.
=============================================================

A few aurora users keep hitting this repeatedly on startup and basically can't use the browser anymore. The allocations are almost 4GB. Perhaps there is an underflow here? http://hg.mozilla.org/releases/mozilla-aurora/annotate/7b0e3c02591f/toolkit/components/url-classifier/nsUrlClassifierPrefixSet.cpp#l322
Flags: needinfo?(gpascutto)
(Reporter)

Comment 1

3 years ago
[Tracking Requested - why for this release]: Perma-startup-crash
status-firefox40: --- → unaffected
status-firefox41: --- → affected
status-firefox42: --- → affected
tracking-firefox41: --- → ?
(Assignee)

Updated

3 years ago
Assignee: nobody → gpascutto
Flags: needinfo?(gpascutto)
(Assignee)

Comment 2

3 years ago
Indeed looks like an underflow caused by a corrupted on disk database.
(Assignee)

Comment 3

2 years ago
Created attachment 8632848 [details] [diff] [review]
Check for corrupted delta array in UrlClassifier
(Assignee)

Updated

2 years ago
Attachment #8632848 - Flags: review?(francois)
Attachment #8632848 - Flags: review?(francois) → review+
(Assignee)

Comment 4

2 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=8096598c05cf
(Assignee)

Comment 5

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/38cbbbad1ffe
https://hg.mozilla.org/mozilla-central/rev/38cbbbad1ffe
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox42: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42

Comment 7

2 years ago
Let's track for FF41, we should be uplifting to Aurora at some point once we know the fix is stable.
tracking-firefox41: ? → +
(Assignee)

Comment 8

2 years ago
Comment on attachment 8632848 [details] [diff] [review]
Check for corrupted delta array in UrlClassifier

Approval Request Comment
[Feature/regressing bug #]: None
[User impact if declined]: Irrecoverable startup crash if specific file gets corrupted.
[Describe test coverage new/current, TreeHerder]: None
[Risks and why]: Worst case some legitimate SafeBrowsing databases get wiped.
[String/UUID change made/needed]: None
Attachment #8632848 - Flags: approval-mozilla-aurora?

Comment 9

2 years ago
Comment on attachment 8632848 [details] [diff] [review]
Check for corrupted delta array in UrlClassifier

Approved, seems like a simple check. Let's uplift to Aurora and hope that it helps.
Attachment #8632848 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/2144e9309d89
status-firefox41: affected → fixed
You need to log in before you can comment on or make changes to this bug.