[Netflix] error F7381-1203: Nightly no longer shows "Enable DRM" info bar when playing a video with DRM disabled

RESOLVED INVALID

Status

()

Core
Audio/Video
P1
normal
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 3 bugs, {regression})

unspecified
x86_64
Windows
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 unaffected, firefox41 unaffected, firefox42 affected)

Details

(Reporter)

Description

3 years ago
STR:
1. Play an EME video on Netflix.
2. Uncheck the "Play DRM Content" checkbox to disable EME.
3. As expected, the video will stop with the following error message:

  Whoops, something went wrong...
  Unexpected Error
  There was an unexpected error. Please reload the page and try again.
  Error Code: F7361-1253

4. Reload the page as instructed.

RESULT:

In Beta 40, reloading the page shows the "Enable DRM" info bar as expected, but in Nightly 42, reloading the page does not show the info bar and reports Netflix Error Code: F7381-1203 (i.e. "Source buffer error event was fired"?).

Enabling "Play DRM Content" in about:preferences#content and then reloading the Netflix page sometimes restarts the video as expected in Nightly 42.
(Reporter)

Comment 1

3 years ago
cpearce, this looks like a regression in Nightly 42. I can reproduce in Nightly 42 whether e10s enabled or disabled. I can't reproduce in Aurora 41 or Beta 40.
status-firefox41: ? → unaffected
Flags: needinfo?(cpearce)
(Reporter)

Comment 2

3 years ago
Curiously, I can reproduce this on Windows 10 (x64) but not Windows 8.1 (x64).
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 3

3 years ago
Are there any errors in the browser console when this happens?
Flags: needinfo?(cpeterson)
(Reporter)

Comment 4

3 years ago
The Netflix player seems to have changed. The bug I originally reported is no longer reproducible. When I now disable DRM while a video is playing and then reload the page as instructed, the "Enable DRM" info bar flashes momentarily but then Netflix quickly falls back to Silverlight (on both Windows 8.1 and 10).

However, if Netflix falls back to Silverlight so quickly, the user will get stuck with Silverlight because they weren't told to reenable DRM. But that's a separate UX issue.

I see the following messages in the browser console, but I see them in both Windows 8.1 and 10:

Media resource mediasource:http://www.netflix.com/4244880c-d879-45c6-8051-7bcd1a008c2a could not be decoded. 393317
in expediteSecureStop wwwplayer-3.0000.043.051.js:977
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(cpeterson)
Flags: needinfo?(cpearce)
OS: Windows 10 → Windows
Resolution: --- → INVALID
(Reporter)

Updated

3 years ago
Blocks: 1184721

Updated

3 years ago
Blocks: 1184785
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.