[FTU]{{undefined}} appears on the 'SIM Manager' page in FTE with 2 sims present

RESOLVED DUPLICATE of bug 1182568

Status

Firefox OS
Gaia::First Time Experience
RESOLVED DUPLICATE of bug 1182568
3 years ago
3 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8632246 [details]
logcat_20150710_1247.txt

Description:
When a user has just flashed their device, or resets their phone, and is proceeding through the First Time Experience with 2 sims they will see debug text present on the SIM manager screen where the label of the sims should be.

Prerequisite:
have 2 sims in the Flame.

Repro Steps:
1) Update a Flame to 20150710010203
2) Proceed through the FTU to the 'SIM Manager' page
3) Observe debug text on screen

Actual:
There is debug text present in the FTU

Expected:
It is expected that users cannot see debug text on the phone

Environmental Variables:
Device: Flame 2.5 [Full Flash]
Build ID: 20150710010203
Gaia: ad76c159c641c977d9140c5fedea84aea04e0e60
Gecko: 2c91d57441fd
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 5/5
See attached: screenshot, logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8632248 [details]
Debug text sim manager
(Reporter)

Comment 2

3 years ago
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20150710002505
Gaia: 84d0c76370dcd3d25813b00de55194730884355b
Gecko: e002005dc994
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
There is no debug text present on the 'SIM Manager' page.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Systemsfe]
[Blocking Requested - why for this release]:
Visible regression of a core app (FTU)

See also bug 1182568, wouldn't be surprised if the same commit caused both of these.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
See Also: → bug 1182568
QA Contact: pcheng
Confirmed that this bug shares the same window as bug 1182568 comment 4.
Blocks: 1169361
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Same issue as bug 1182568, this is the {{brandShortName}} variable that should be populated into these strings
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1182568
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: 2.5? → ---
You need to log in before you can comment on or make changes to this bug.