Closed Bug 1182639 Opened 7 years ago Closed 7 years ago

In first time use wizard, switching wireless networks repeatedly seems to cause a confused visual state

Categories

(Firefox OS Graveyard :: Gaia::System::Wifi, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: gkw, Assigned: timhuang)

Details

(Keywords: foxfood, Whiteboard: [bzlite])

Attachments

(4 files)

User-Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

1. When selecting wireless networks, repeatedly tap on a particular non-password protected network.
2. Connect successfully to another password-protected network.
3. The password-protected network is connected to, but the screen still shows it's trying to connect to the original one in step 1.
Attached image screenshot
Screenshot showing previous wireless network still being in the "Connecting..." status while connected to new network.
Attachment #8632263 - Attachment mime type: application/octet-stream → text/plain
Attachment #8632264 - Attachment mime type: application/octet-stream → text/plain
Attachment #8632265 - Attachment mime type: application/octet-stream → text/plain
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → Gaia::System::Wifi
This seems to be relevant to the synchronization issue of Wi-Fi status between Gaia and Gecko that we had discussed recently.
Tim, can you help to confirm the root cause?
Flags: needinfo?(tihuang)
Assignee: nobody → tihuang
Priority: -- → P2
I cannot reproduce this issue on my aries. And I am wondering that should I wait for non-password protected network becomes connected or not before connecting to password protected netowrk to reproduce this issue.
Flags: needinfo?(tihuang) → needinfo?(gary)
I am unable to confirm this now due to various circumstances, either. Will file a new bug if it shows up again.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(gary)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.