Closed Bug 1182643 Opened 4 years ago Closed 4 years ago

[Control Center] panel is closed when I try to change site permissions

Categories

(Firefox :: General, defect, P1)

42 Branch
defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 42
Iteration:
42.1 - Jul 13
Tracking Status
firefox41 --- verified
firefox42 + verified

People

(Reporter: alice0775, Assigned: ttaubert)

References

Details

(Keywords: regression, Whiteboard: [fxprivacy] [campaign])

Attachments

(1 file)

[Tracking Requested - why for this release]:

This problem appears on Nightly42.0a1 but not on Aurora41.0a2.


Steps To Reproduce:
1. Open https://addons.mozilla.org/en-US/firefox/
2. Click "identity-box" in locationbar
3. Attempt to change site permissions:
   Click select box
4. If not reproduce the problem, reload(F5) and go to step2 then step3

Actual Results:
The site identity panel is closed.
So I cannot change it.

Expected Results:
Dropdown list of the site permissions should pop up
Regression range:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=9442599cebf8&tochange=9a607079f868

Regressed by: 9a607079f868	Tim Taubert — Bug 1180642 - [Control Center] Close panel when an element outside the panel receives focus r=Gijs
Blocks: 1180642
Flags: needinfo?(ttaubert)
Flags: firefox-backlog?
Whiteboard: [fxprivacy]
Note,
This should be reproduced without e10s
Summary: site identity panel is closed when I try to change site permissions in site identity panel, So I cannot change it. → [non-e10s] site identity panel is closed when I try to change site permissions in site identity panel, So I cannot change it.
Summary: [non-e10s] site identity panel is closed when I try to change site permissions in site identity panel, So I cannot change it. → [Control Center] panel is closed when I try to change site permissions
For reasons I don't understand the #main-window gets focus when clicking a pref dropdown. The same thing happens when trying to navigate by hitting <tab>, in non-e10s Firefox only.
Flags: needinfo?(ttaubert)
See Also: → 1182512
Flags: firefox-backlog? → firefox-backlog+
Duplicate of this bug: 1182872
See Also: 1182512
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Iteration: --- → 42.1 - Jul 13
Points: --- → 3
Flags: qe-verify+
I can't explain what happens in non-e10s mode and why the parent window gets focused when clicking a dropdown but I think we can easily fix this by allowing the identity popup's ancestors to be focused as well. The patch works well for me with and without e10s.
Attachment #8632788 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8632788 [details] [diff] [review]
0001-Bug-1182643-Control-Center-Fix-non-e10s-issues-with-.patch

Review of attachment 8632788 [details] [diff] [review]:
-----------------------------------------------------------------

I trust your testing; rs=me
Attachment #8632788 - Flags: review?(gijskruitbosch+bugs) → review+
Blocks: 1168883
Rank: 1
Priority: -- → P1
QA Contact: mwobensmith
https://hg.mozilla.org/mozilla-central/rev/4e24a118876c
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Comment on attachment 8632788 [details] [diff] [review]
0001-Bug-1182643-Control-Center-Fix-non-e10s-issues-with-.patch

Approval Request Comment
[Feature/regressing bug #]: Bug 1180642
[User impact if declined]: Need this to uplift bug 1180642.
[Describe test coverage new/current, TreeHerder]: None.
[Risks and why]: Low risk.
[String/UUID change made/needed]: None.
Attachment #8632788 - Flags: approval-mozilla-aurora?
Comment on attachment 8632788 [details] [diff] [review]
0001-Bug-1182643-Control-Center-Fix-non-e10s-issues-with-.patch

Patch looks safe. Let's land it in Aurora.
Attachment #8632788 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [fxprivacy] → [fxprivacy] [campaign]
Verified as fixed using:

FF 42 Build Id: 20150728030209
FF 41 Build Id: 20150729004002

OS: Win 7 x64, Ubuntu 14.04 x32, Mac Os X 10.10.4
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1182512
You need to log in before you can comment on or make changes to this bug.