ring using find my phone almost inaudible

RESOLVED WORKSFORME

Status

Firefox OS
FindMyDevice
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: jya, Assigned: gerard)

Tracking

({dogfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite])

User-Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

I couldn't locate my phone so I using the find my phone series. 

I was standing 1m away from the phone. Yet I could barely hear the ringtone. 

Seems like it doesn't use maximum audio volume but the currently set volume (which could be low)

expected result: find my phone make the phone rings at maximum volume.
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → FindMyDevice
Alexandre, could you take a look at this please ?
Assignee: nobody → lissyx+mozillians
(Assignee)

Comment 2

3 years ago
We have support for that. Bug 1147862 is the last one that made a change there and set the audio channel type to "ringer".
(Assignee)

Comment 3

3 years ago
Audio channel "ringer" seems to be mapped to "audio.volume.notification" to control the level: https://github.com/mozilla-b2g/gaia/blob/cba7e4b86361af31b153cfebaf99900e0b860f7b/apps/system/js/sound_manager.js#L476

FMD does change this: https://github.com/mozilla-b2g/gaia/blob/cba7e4b86361af31b153cfebaf99900e0b860f7b/apps/findmydevice/js/commands.js#L203

Now, that bug is very old and a lot have moved. Can we get QA to check if that gets reproduced?
Keywords: qawanted
(Assignee)

Comment 4

3 years ago
I clearly don't reproduce the issue on my side: I have set volume to 0. Then used the feature on FMD website. Ringer worked and the volume got set to the maximum.
Flags: needinfo?(jyavenard)
Yes, now the volume is set to the maximum.

A pity it doesn't also vibrate however...
Flags: needinfo?(jyavenard)
(In reply to Jean-Yves Avenard [:jya] from comment #5)
> Yes, now the volume is set to the maximum.
> 
> A pity it doesn't also vibrate however...

Did you file a bug for that?
I did not.
QA cannot reproduce this on latest Aries. According to reporter this is not reproducing for them on latest either. FMD Rings the device with maximum volume.

No repro on:
Device: Aries
BuildID: 20151123143009
Gaia: bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Gecko: d3d286102ba7f8801e9dfe12d534f49554ba50c0
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
QA Whiteboard: [foxfood-triage] → [foxfood-triage] [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Jean-Yves are we okay to close this issue as WFM?  We can reopen if it occurs again.
QA Whiteboard: [foxfood-triage] [QAnalyst-Triage?] → [foxfood-triage] [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(jyavenard)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jyavenard)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.