Closed Bug 1182784 Opened 5 years ago Closed 2 years ago

[foxfooding][Aries] Ringtone can be heard from ear piece after incoming call

Categories

(Firefox OS Graveyard :: AudioChannel, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: shawnjohnjr, Unassigned)

References

Details

(Keywords: dogfood, Whiteboard: [bzlite])

User-Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

1. Answer an incoming call
2. Call ended hang up.
3. Another incoming call received
4. Ringtone can be heard from ear piece instead of speaker, low volume makes me missing many calls.
Hi Alastor,
Do you have any idea? I used non-default ringtone (imported ringtone from mp3 file).
Flags: needinfo?(alwu)
Component: Gaia::Feedback → AudioChannel
(In reply to Shawn Huang [:shawnjohnjr] from comment #0)
> User-Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
> 
> 1. Answer an incoming call
> 2. Call ended hang up.
> 3. Another incoming call received
> 4. Ringtone can be heard from ear piece instead of speaker, low volume makes
> me missing many calls.

When the symptom happened, I can always hit the same bug whenever there is an incoming call, which is 100% reproducible. However, I don't know the exact steps now to reproduce this problem, although Comment 0 is my exact scenario :(
Hi, Shawn,
I think this issue might be the same as the bug1115304 (caused by the telephony AudioContext in audio_competing_helper.js). 

In m-c, we can use the new audio channel architecture to fix it. However, in other versions, the only method we have is to remove this workaround, because we don't have plan to uplift new audio channel architecture to other version.
Flags: needinfo?(alwu)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
I think the bug185442 can solve this issue, it would remove the workaround in audio_competing_helper.js.
QA Whiteboard: [foxfood-triage]
I've tried this with the fix for bug 1185733 applied on my Flame and this doesn't occur so closing as a dup, please reopen if I'm wrong.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1185733
It seems that my old assumption is wrong, the issue still exists even if the bug1185442 landed.
After preliminary analysis, the problem might be in the SONY's Android HAL, probably in the AudioPolicyManager.cpp.
I need to ask the SONY people for more details.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
STR.
1. Make a call 
2. Hang out the call, before the call connects
3. Receive an incoming call

Expected.
4. Incoming ringtone is out from the speaker.

Actual.
4. Incoming ringtone is out from the receiver.

---

If you make a call, and this call doesn't be connected. Next incoming call would be out from the wrong output device. It would be continually wrong until we play another audio. (ex. play music)

I think that the AudioPolicyManager might not handle the correct call state or there is another logic to use the receiver.
blocking-b2g: 2.5? → 2.5+
(In reply to Alastor Wu [:alwu] from comment #8)
> STR.
> 1. Make a call 
> 2. Hang out the call, before the call connects
> 3. Receive an incoming call
> 
> Expected.
> 4. Incoming ringtone is out from the speaker.
> 
> Actual.
> 4. Incoming ringtone is out from the receiver.
> 
> ---
> 
> If you make a call, and this call doesn't be connected. Next incoming call
> would be out from the wrong output device. It would be continually wrong
> until we play another audio. (ex. play music)
> 
> I think that the AudioPolicyManager might not handle the correct call state
> or there is another logic to use the receiver.

Can we build AudioPolicyManager to debug?
No, we only have a shared library, this is provided by partner. 
I have already asked the SONY people, but they doesn't reply me yet.
Mahe, let's unblock this issue from 2.5.

As Alastor's comment 7 and comment 10, we need Sony's support to fix bug. I can't find sony's point of contact. Please let me know if anyone have contact.
Blocks: spark-device
blocking-b2g: 2.5+ → ---
Flags: needinfo?(mpotharaju)
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Summary: [foxfooding] Ringtone can be heard from ear piece after incoming call → [foxfooding][Aries] Ringtone can be heard from ear piece after incoming call
Sure Bobby. Unblocking for 2.5 per comment 11. 

Please see 1192187. Seems like a similar bug.
Flags: needinfo?(mpotharaju)
Priority: -- → P2
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.