Firefox Account lost on reboot when Firefox installed on SD card

RESOLVED INVALID

Status

Android Background Services
Firefox Accounts
RESOLVED INVALID
3 years ago
5 months ago

People

(Reporter: H Prime, Unassigned)

Tracking

Firefox 39

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324
Firefox for Android

Steps to reproduce:

Install Firefox android on Sd card.  Set up sync.  initiate and complete sync.  Everything works.
Reboot Phone.



Actual results:

After reboot FF tells you it cannot connect to Sync.  Open the notification and see the password is missing.  You can reenter password ,but it will fail again upon each reboot.


Expected results:

FF should have remembered the Sync credentials.  

If you do not move FF to SD card it does not have this issue.
Component: Untriaged → Firefox Accounts
Product: Firefox → Android Background Services
Summary: on firefox android stored on SD card; sync password is lost upon reboot → Firefox Account lost on reboot when Firefox installed on SD card
Version: 39 Branch → Firefox 39
There have been changes over time to the pickling code.  It's possible we made an error along the way.  Clearly pickling is mostly working, since the Account persists but the state does not.  It's possible, since there's a reboot involved, that we're seeing a problem with the phone's clock and timestamping from the remote server.

If somebody can reproduce and attach |adb logcat| output after running |adb shell setprop log.tag.FxAccounts VERBOSE|, that would be helpful.
We don't allow installing to the SDcard any more.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.