Erratic text selection in textarea with scrolling

RESOLVED WORKSFORME

Status

()

Firefox for Android
Text Selection
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Nicolae Albu, Unassigned)

Tracking

39 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

1. Go to a page that has a textarea with many lines of text so you have scrolling. Replying to a (long) Bugzilla comment is a perfect use case.
2. Tap and hold on a word to begin text selection.
3. Drag downwards or upwards to select text, including text not visible (but scrollable).


Actual results:

The text selection is erratic. It deselects parts of the previously selected text, it moves the opposing carret.
Here is an example video: http://youtu.be/EBSSUXN9XU0


Expected results:

It should select more text in the direction of the movement, including the scrollable text.
It should not deselect already selected text unless the direction of the movement causes that.
It should not move the carret opposing the one which is moved.
(Reporter)

Updated

3 years ago
OS: Unspecified → Android
Hardware: Unspecified → ARM
It appears I can't view the HTML5 video yet in FF/Nightly, but that's a separate bug ;-)

I did quickly look at it using Chrome. We've completed a new version of TextSelection handles/carets (bug 988143) and will be rolling it out soon (?) tracking on Bug 1168847.

You can test the new version against a nightly build, by enabling both about:config prefs "selectioncaret.enabled" and "touchcaret.enabled".
(Reporter)

Comment 2

3 years ago
Looks like with the new carets on nightly, the problem is fixed.
awesome! Care to close this? RESOLVED/WONTFIX?
(Reporter)

Comment 4

3 years ago
Works in nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.