When login to gmail using LastPass, freeze Firefox

RESOLVED DUPLICATE of bug 1251772

Status

()

Firefox
Extension Compatibility
RESOLVED DUPLICATE of bug 1251772
2 years ago
a year ago

People

(Reporter: PRiMENON, Unassigned)

Tracking

42 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(platform-rel -)

Details

(Whiteboard: [platform-rel-Google] [platform-rel-Gmail])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150711030210

Steps to reproduce:

Build identifier: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Built from https://hg.mozilla.org/mozilla-central/rev/9f2b81411bf5

Steps to reproduce:
1.create clean profile, and start nightly.
2.install LastPass v3.1.95(release) add-ons.
3.restart firefox nightly, close to "Welcome to LastPass!" window, click to "no thanks".
4.click to LastPass button, login to LastPass.
5.open Gmail website, click to LastPass button, pulldown menus select "show matching sites", -> "your google account" -> "auto Fill".
6.input LastPass master login.



Actual results:

freeze firefox.
firefox.exe process killed task manager, displayed dialog "Plugin Container for Nightly process stop."


Expected results:

don't freeze firefox, and login Gmail.
(Reporter)

Updated

2 years ago
Component: Untriaged → Extension Compatibility
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64

Comment 1

2 years ago
I experience the same hang on my Mac using 42.0a2, but for all login forms (not just Gmail) and only with electrolysis (e10s) enabled.

Assuming the original reporter also has e10s enabled (which it should be, by default), this seems to be identical to the issue logged in Bug 1188912, which was duped against Bug 1008768.

The work-around suggested in those bugs was to install an e10s-compatable preview/dev build from:

https://rodan.lastpass.com/dev/lp_e10s.xpi

I'm still trying to figure out which about:config spells will allow me to either install or just download that file in DE 42.
Whiteboard: [platform-rel-Google] [platform-rel-Gmail]
platform-rel: --- → ?
platform-rel: ? → -
I think gmail is just one example of general lastpass issues with e10s. Feel free to un-dupe if I'm incorrect.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1251772
You need to log in before you can comment on or make changes to this bug.