Closed Bug 1182932 Opened 5 years ago Closed 4 years ago

www.arcgames.com is passing credentials over RC4

Categories

(Web Compatibility :: Desktop, defect)

Firefox 39
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lh.bennett, Unassigned)

References

()

Details

https://www.arcgames.com/en/sign/in

Despite getting a brand new issuer(GoDaddy>Comodo) after July 11th, they still use RC4 over TLS 1.2 for logins despite users telling them about the issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is this still an issue? Looks like https://www.arcgames.com/en/sign/in is fixed, but I don't have an account to check whether actually trying to log in works.
Flags: needinfo?(lh.bennett)
It seems fixed. The website reports AES 256 CBC over TLS 1.2. No problems with the login.
Flags: needinfo?(lh.bennett)
Thanks for checking.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
It looks like the site has regressed back to being RC4 only.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Fixed again.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.