Recent change in format of "undisclosed-recipients:;" (one space added before semicolon)

RESOLVED WONTFIX

Status

Thunderbird
Untriaged
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: David White, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20131205075310

Steps to reproduce:

Users indicated that my UseBccInstead addon stopped working in its extended-recipients column for the thread pane. They said it began with version 38.0.1 of TB. My addon looks for the string "undisclosed-recipients:;" in the TO header and this was failing to be found.

I changed my code to dump the contents of the TO header for a newly sent email (using 38.0.1) which contained only BCC recipients. What I found is that the TO header now contains "undisclosed-recipients: ;" (note space between : and ;.


Actual results:

TO headers are containing "undisclosed-recipients: ;" instead of "undisclosed-recipients:;" for messages sent with only BCC recipients using TB 38.0.1.


Expected results:

I believe that the proper format from the spec says this should be "undisclosed-recipients:;" and it has always been this way in TB until recently. I am not sure if this is a bug or a desired change. But it does break my addon and I do not see the change documented (but I easily might have missed that).
Joshua, can you comment on this?
Flags: needinfo?(Pidgeot18)
Summary: Recent change in format of "undisclosed-recipients:;" → Recent change in format of "undisclosed-recipients:;" (one space added before semicolon)
(Reporter)

Comment 2

3 years ago
For what it may be worth, a user of my addon reported that he upgraded Thunderbird to version 38.1.0. And now my addon works like it did earlier. I have not personally checked this due to lack of time. But maybe this was caught/fixed already?
(In reply to David White from comment #0)
> I believe that the proper format from the spec says this should be
> "undisclosed-recipients:;" and it has always been this way in TB until
> recently. I am not sure if this is a bug or a desired change. But it does
> break my addon and I do not see the change documented (but I easily might
> have missed that).

http://tools.ietf.org/html/rfc5322#section-3.4
   group           =   display-name ":" [group-list] ";" [CFWS]
   group-list      =   mailbox-list / CFWS / obs-group-list

undisclosed-recipients:; and undisclosed-recipients: ; are both equally valid and semantically identical.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(Pidgeot18)
Resolution: --- → WONTFIX
(Reporter)

Comment 4

3 years ago
So this was done on purpose? There was an active decision to change this from ":;" to ": ;"? Interesting...
(In reply to David White from comment #4)
> So this was done on purpose? There was an active decision to change this
> from ":;" to ": ;"? Interesting...

I noticed the change, but the extra space is a fallout of some generic logic, and the extra logic required to eliminate it in emission isn't worth the aesthetics.
(Reporter)

Comment 6

3 years ago
Well, it really isn't a question of aesthetics for my addon. The change breaks it since it was looking for the old pattern. I can, of course, change my addon. I have this done and now have to submit the changes, etc to AMO.

I don't know if this is related or not. But prior to TB 38, if a message is sent with only BCC'ed recipients and if the pref "mail.compose.add_undisclosed_recipients" is set (which it always seemed to be by default), the TO address was always shown as "undisclosed-recipients:;". I note that now the TO address is shown blank. Any idea if this was intended or just another "fallout"?
You need to log in before you can comment on or make changes to this bug.