Clicking "load more" button shows duplicate reviews

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: valentina.peleskei, Unassigned)

Tracking

Avenir
2015-07-14
x86_64
Windows 7
Points:
---

Details

(Whiteboard: [see comment 1][marketplace-transition], URL)

(Reporter)

Description

4 years ago
Steps to reproduce:
1. Load MP-stage homepage https://marketplace.allizom.org/
2. Go to any app details page and submit a review (an app with few reviews is more appropriate to see the issue)
3. Go to Reviews page and refresh

Expected results:
There are no display or layout issues. All reviews are there.

Actual results:
The first review is erased.

Notes/Issues:
Verified on FF42(Win 7). Issue is only reproducing on MP-stage.
Screencast for this issue: http://screencast.com/t/oOOucJJQD
We don't make a request between adding a review and listing the reviews. So we just prepend our list of reviews with the one that was just added. This means we end up with 25 reviews being listed instead of the initial 24. When the page is refreshed we only show 24 results so the last one on the page is now gone.

Another bug that happens is if instead of reloading the page you hit "load more" then you get the last review duplicated since we just pushed off the bottom of the first page to the top of the second page.

You can also get duplicate reviews if someone else adds a review between the time you loaded the initial set of reviews and when you click "load more". You could get multiple duplicate reviews if multiple new reviews are added.

We should probably do a rewrite with clojure/clojurescript and datomic to avoid this in the future.
Priority: -- → P3

Updated

4 years ago
Summary: Refreshing the Reviews page after a review is submitted erases the first review of that app → Clicking "load more" button shows duplicate reviews
Whiteboard: [see comment 1]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Whiteboard: [see comment 1] → [see comment 1][marketplace-transition]
You need to log in before you can comment on or make changes to this bug.