Refetch FxA credentials (including sync keys if needed) when "services.sync.enabled" pref changes

RESOLVED DUPLICATE of bug 1211606

Status

Firefox OS
FxA
RESOLVED DUPLICATE of bug 1211606
3 years ago
3 years ago

People

(Reporter: ferjm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
By default, the Firefox Accounts client on B2G does not fetch Sync keys [1], basically cause we still have no Firefox Sync client on B2G. Bug 1182071 changes that in a way that we fetch the Sync keys iif the "services.sync.enabled" pref is enabled. We'll need to observe changes on this preference once we have the UI bits to enable/disable Firefox Sync on FxOS. When this pref changes, we may need to refetch FxA credentials and ask for the Sync keys.

[1] https://github.com/mozilla/fxa-auth-server/wiki/onepw-protocol#-fetching-sync-keys
(Reporter)

Updated

3 years ago
Blocks: 824026
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1211606
You need to log in before you can comment on or make changes to this bug.