From: should be displayed as it was delivered

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Toralf Förster, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8632798 [details]
[portage] ebuild log for net-misc_tor-0.2.6.10 on tor-relay.zwiebeltoralf.de.eml

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150711190510

Steps to reproduce:

I get emails send by my tinderbox to my (technical) account.
I use ssmtp (a very simple MTA) for transfering the mails from my server to my IMAP hoster.
The From: contains particular different user strings



Actual results:

Those user strings are not displayed, instead I always see "Me"


Expected results:

As in the example, show 
From: portage tor-relay <tor-relay@zwiebeltoralf.de>
rather than From: "Me ...."
(Reporter)

Comment 1

2 years ago
Created attachment 8632799 [details]
screen shot showing the current From: line
Toralf, there's an option in settings which achieves what you want:
Tools > Options > Display > Advanced > [ ] Show only display names for people in my address book
Uncheck that option, and you'll see the real strings in the message header.
(Unfortunately it won't work for the recipients column and other columns, but that's another story).

Please let us know if that solves your scenario, or what other improvements you'd suggest.

In the meantime, I'll close this bug as invalid because we're offering that functionality.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.