Closed Bug 1183163 Opened 9 years ago Closed 5 months ago

Investigate CSS flex performance issues compared to XUL flexbox

Categories

(Core :: Layout, defect)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox42 --- affected

People

(Reporter: bzbarsky, Assigned: dholbert)

References

(Blocks 1 open bug)

Details

(Whiteboard: [layout:backlog:2020])

Attachments

(2 files)

Neil Deakin has a blog post at https://enndeakin.wordpress.com/2015/07/13/comparing-flexible-box-layouts/ with some charts, but no links to testcases.  Getting those testcases attached here would be useful.
Flags: needinfo?(enndeakin)
Flags: needinfo?(dholbert)
Neil, if you have a patch-stack that CSS-flexifies a mozilla-central build (and reproduces the issues documented in your blog post), I'd love to work with that patch-stack locally & see what I can find.
Flags: needinfo?(dholbert)
(In reply to Daniel Holbert [:dholbert] from comment #1)
> Neil, if you have a patch-stack that CSS-flexifies a mozilla-central build

Ah, turns out this was simpler than I expected; I just tried adding a line to the end of browser.css, per the end of https://enndeakin.wordpress.com/ , and was able to trigger some pathological slowness.
This patch triggers the pathological case discussed at the end of Neil's blogpost -- it makes startup take ages (I waited several minutes with 100% CPU and still hadn't seen a window yet).
For comparison, here's a patch to make everything -moz-box instead of flex. With this, startup is pretty quick.
Flags: needinfo?(enndeakin) → needinfo?(dholbert)
Attachment #8641927 - Attachment description: demo-patch #1: make everything display:flex, in browser.css → demo-patch #1: make everything display:flex, in browser.css [SLOW]
Assignee: nobody → dholbert
See Also: → 1398963
Depends on: 1449346
Whiteboard: [layout:backlog:2019q3]
Whiteboard: [layout:backlog:2019q3] → [layout:backlog:2020]
Severity: normal → S3

I think we can call this FIXED as a meta-issue at this point; we've fixed the known issues and we've removed XUL flexbox entirely.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(dholbert)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: