run-gdb.sh bad quoting on line that runs gdbserver

RESOLVED DUPLICATE of bug 1207280

Status

Firefox OS
GonkIntegration
RESOLVED DUPLICATE of bug 1207280
3 years ago
2 years ago

People

(Reporter: garvan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Problem: run-gdb.sh fails with can't fine libmozglue.so

Actual problem:
run-gdb.sh with set -x shows the gdbserver line as:

+ adb shell DMD= LD_LIBRARY_PATH=/system/b2g 'LD_PRELOAD="' '/system/b2g/libmozglue.so"' TMPDIR=/data/local/tmp gdbserver --multi :10501 /system/b2g/b2g

The LD_PRELOAD quoting is bad. The actual line in the file is:
LD_PRELOAD=\"$ld_preload_extra /system/b2g/libmozglue.so\"

This A=\"$foo b\" is being turned into 'A="'' b"'  with $foo turned into single quotes which is terminating the string early.

The lines in run-gdb.sh that affect this are unchanged since 2012, so why this has suddenly stopped working I have no idea.

Comment 1

2 years ago
Personal communication from Fabrice: It's a problem on Linux too.

Updated

2 years ago
Summary: run-gdb.sh bad quoting on line that runs gdbserver (mac-only?) → run-gdb.sh bad quoting on line that runs gdbserver
abd vesion 1.0.32 pases the command line differently from adb 1.0.31
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1207280
You need to log in before you can comment on or make changes to this bug.