searching by date finds one day older messages

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: joel, Assigned: naving)

Tracking

({qawanted})

Trunk
x86
Linux
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122108

When I try to search messages by date Mozilla finds one day older messages (I
search 1/4/2002, Mozilla finds 1/3/2002). 


Reproducible: Always
Steps to Reproduce:
1.Open mail window
2.Open search dialog
3.Search by date (eg. 1/4/2002)


Actual Results:  I get all letters sent to me on 1/3/2002

Expected Results:  I should have got all letters sent to me on 1/4/2002

I use Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221 from
mozilla-i686-pc-linux-gnu-0.9.7.tar.gz on RH7.2

Comment 1

17 years ago
I just tried using 2002010403 build w2k, 

I have 4 mail messages in my local send folder:

mailnews > search > search messages > date > is '1/5/2002'  and it found 2 of
them correctly.  I have 2 messages from '1/4/2002' but they didn't get returned
in the results.  So in this build it works for me.  Can you try a newer
build/new profile please, to see if it is not just the build, although it is
very likely it is another one of the linux only bugs.

Updated

17 years ago
Keywords: qawanted

Comment 2

17 years ago
WFM  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020115

Comment 3

17 years ago
WFM Linux Mozilla 0.9.8
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
verified worksforme with feb12 commercial trunk, linux rh6.2. OK IMAP and local
mail.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.