Closed Bug 1183290 Opened 6 years ago Closed 6 years ago

Take patch from Bug 1176671 (Change lang attribute when dictionary is changed) for SeaMonkey 2.35

Categories

(SeaMonkey :: MailNews: Composition, defect)

SeaMonkey 2.35 Branch
defect
Not set
normal

Tracking

(seamonkey2.35 fixed)

RESOLVED FIXED
seamonkey2.35
Tracking Status
seamonkey2.35 --- fixed

People

(Reporter: philip.chee, Assigned: philip.chee)

References

Details

Attachments

(1 file)

(In reply to Thomas D. from comment #0)
> STR
> 
> 0 default spell check language set to EN in Options > composition; install
> DE-DE dictionary (e.g. right-click on composition msg body > languages > add
> dictionaries)
> 
> 1 compose email msg, for demonstration with DE and EN language text
> subject: Hello World - Hallo zusammen
> body: This is English with - Das ist Deutsch
> 
> 2 place focus in body (because spelling button is wrongly disabled in
> subject, unrecorded bug, the other half of bug 368915)
> 
> 3 click "Spelling" button
> 
> 4 change dictionary from English/Untited States to German/Germany and watch
> inline spelling change in background
> 
> 5 optionally click any button like recheck, ignore, replace to confirm that
> you're actually using the new dictionary (but this shouldn't be necessary)
> 
> 6 Verify and remember which language you have chosen (DE) and then click
> "close" button in spelling dialogue
> 
> 7 Look at inline spelling marks, and verify current language from dual
> spelling button
> 
> Actual result
> 
> 4) when changing dictionary, inline spelling is updated as long as spell
> dialogue is open (to DE)
> 7) but after closing the dialogue, it reverts back to the original language
> setting which was EN
> 
> Expected result
> 
> 7) Chosing another dictionary in spell dialogue must be persisted after
> closing the dialogue (with or without further action)
> 
> (Also, it looks like another bug, probably in editor's spell-check dialogue,
> that TB immediately applies the new language to the text in background but
> DOES NOT update the list of suggestions *in* the dialogue to the new
> language - this should be synchronized somehow)
[Approval Request Comment]
Regression caused by (bug #): bug 967494
User impact if declined: Changing dictionary language from spellcheck dialogue is not persisted after closing the dialogue
Testing completed (on m-c, etc.): Tested on Thunderbird esr38
Risk to taking this patch (and alternatives if risky): low risk bug fix.
String changes made by this patch: none
Attachment #8632967 - Flags: approval-comm-release?
Attachment #8632967 - Flags: approval-comm-release? → approval-comm-release+
http://hg.mozilla.org/releases/comm-release/rev/02705c8c2186
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.35
You need to log in before you can comment on or make changes to this bug.