[Call Screen][Emergency Call] 'Search the web' present on status bar on the emergency call screen, not selectable or functional.

RESOLVED DUPLICATE of bug 1184672

Status

Firefox OS
Gaia::System::Browser Chrome
RESOLVED DUPLICATE of bug 1184672
3 years ago
3 years ago

People

(Reporter: Marty, Assigned: sfoster)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8633135 [details]
Search-Emergency-Screenshot.png

Description:
If the user has a passcode enabled and makes an emergency call, they will still see the 'Search the web' option on the status bar, but tapping this option yields no functionality.

Repro Steps:
1) Update a Aries to 20150713103207
2) In the Settings app, enable a lockscreen passcode
3) In the Contacts app, create a contact and set it as an ICE contact.
4) Lock the device
5) At the lockscreen, swipe to the right to bring up the passcode keypad, and select 'Emergency Call'
6) Call the ICE contact using the red option above the dial pad.
7) Tap the 'Search the web' icon in the status bar while in the call.

Actual:
The 'Search the web' icon is present, but has no functionality.

Expected:
All visible icons are functional when tapped. If the user isn't expected to be able to search while the device is locked and in an emergency call, the 'Search the web' option should not be present.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150713103207
Gaia: a7439b6ca88264734171ff5ea0b6a0b8df3f258e
Gecko: 38d03bf4616e
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 10/10
See attached: Screenshot, Logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8633136 [details]
email-logcat.txt
(Reporter)

Comment 2

3 years ago
This issue DOES occur on Flame 2.5 and 2.2 builds.
The 'Search the web' icon is present, but has no functionality.

Environmental Variables:
Device: Flame 2.5
Build ID: 20150713010204
Gaia: e4b63559eba364892867eb381c3002d6518e5d6a
Gecko: eab21ec484bb
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.2
Build ID: 20150710002505
Gaia: 84d0c76370dcd3d25813b00de55194730884355b
Gecko: e002005dc994
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

-------------------------------------------------

This issue does NOT occur on Flame 2.1 builds.
The 'Search the web' icon is not resent

Environmental Variables:
Device: Flame 2.1
Build ID: 20150702001208
Gaia: 7080a7c28b0242f81d689d2339dfa1177e23f48f
Gecko: c201e76c63d1
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Visible regression that prevents a functional piece which doesn't respond.

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150410122939
Gaia: 89ffba69bc0a3830181358f942a263f2734cfccc
Gecko: 1b0596009f2d
Version: 40.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken
Device: Flame
BuildID: 20150410142339
Gaia: 2e3668c5e91700c97d8e6e2e71e3af8edbfe8a36
Gecko: d4b05f6f623d
Version: 40.0a1 (2.5 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia First Broken Gecko - no repro
Gaia: 89ffba69bc0a3830181358f942a263f2734cfccc
Gecko: d4b05f6f623d

Last Working Gecko First Broken Gaia - repro
Gaia: 2e3668c5e91700c97d8e6e2e71e3af8edbfe8a36
Gecko: 1b0596009f2d

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/89ffba69bc0a3830181358f942a263f2734cfccc...2e3668c5e91700c97d8e6e2e71e3af8edbfe8a36

Caused by changes made in Bug 1151925.
Blocks: 1151925
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Sam, can you take a look at this please? This might have been caused by the landing for bug 1151925.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(sfoster)
(Assignee)

Comment 6

3 years ago
I'm trying to reproduce this on a flame (updated to today's Gaia master) and I get through most of the STR but picking an emergency contact from the ICE list presented from the dialer gives me "this is not an emergency contact". I've also had Contacts crash on me. As it stands I'm not able to investigate. Fwd-ing the need-info to Francisco.
Flags: needinfo?(sfoster) → needinfo?(francisco)
Depends on: 1184522
Based on regression window.

I did experience the "not an ICE error" but not the crash. I opened bug 1184522 and NI Borja there as he's working on the NGA changes in Contacts.

As the current issue didn't exist 3 days ago, do you think it's possible to patch it without being on the most recent Gaia, Sam?
Component: Gaia::Dialer → Gaia::System::Browser Chrome
Flags: needinfo?(francisco) → needinfo?(sfoster)
(Assignee)

Comment 8

3 years ago
I'll look into it
Assignee: nobody → sfoster
Flags: needinfo?(sfoster)
blocking-b2g: 2.5? → 2.5+
Is this a duplicate of bug 1184672?
blocking-b2g: 2.5+ → 2.5?
Flags: needinfo?(sfoster)
Flags: needinfo?(apastor)
blocking-b2g: 2.5? → 2.5+
Indeed, Ben :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(apastor)
Resolution: --- → DUPLICATE
Duplicate of bug: 1184672
(Assignee)

Updated

3 years ago
Flags: needinfo?(sfoster)
blocking-b2g: 2.5+ → ---
You need to log in before you can comment on or make changes to this bug.