Closed Bug 1183379 Opened 5 years ago Closed 5 years ago

Add Amharic (am), Upper Sorbian (hsb), Lower Sorbian (dsb), Miahuatlán Zapotec (zam) locales to Gaia on master and 2.2 branches

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-v2.2r fixed, b2g-master fixed)

RESOLVED FIXED
FxOS-S4 (07Aug)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-v2.2r --- fixed
b2g-master --- fixed

People

(Reporter: tchevalier, Assigned: tchevalier)

References

Details

Attachments

(1 file)

Let's gather in the same place all the locales we're adding so that we can reduce paperwork.
In the end, we're adding them all to the same branches so now it makes more sense to do one patch.
Duplicate of this bug: 1180023
Blocks: 1181865
Duplicate of this bug: 1181829
Blocks: 1145940
Blocks: 1183197
I made the assumption on my founding that translated name for zam was Zapoteco de Miahuatlán, still requires confirmation from localizers.
Hey Rodrigo, one last question, could you check if I got the translated name of your locale right?

"Zapoteco de Miahuatlán" will be displayed in Settings to the user so that he can pick the language, is that correct for your locale?
Flags: needinfo?(rodrigo_perez_r)
Hi Theo, is correct.
Flags: needinfo?(rodrigo_perez_r)
Comment on attachment 8633159 [details] [review]
[gaia] TheoChevalier:new-gaia-locales > mozilla-b2g:master

Hey Stas, finally got the patch to review :)
Attachment #8633159 - Flags: review?(stas)
(In reply to rodrigo_perez_r from comment #6)
> Hi Theo, is correct.

Thanks!
Comment on attachment 8633159 [details] [review]
[gaia] TheoChevalier:new-gaia-locales > mozilla-b2g:master

Great to see so many new languages!  r=me.
Attachment #8633159 - Flags: review?(stas) → review+
Thanks, stas!
Assignee: nobody → theo
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/4729c9872220e4dd067814e3b41dde2737853c9f

Please request Gaia v2.2 approval on this when you get a chance.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(theo)
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S4 (07Aug)
Hi Josh,

Delphine told me to NI you on this one.
Is that possible to uplift this patch to 2.2 please? This is low-risk and those locales are complete (or about to be complete), so that localizers can see their work and we can get them ready in case a partner requests any of them.
blocking-b2g: --- → 2.2?
Flags: needinfo?(theo) → needinfo?(jocheng)
(In reply to Théo Chevalier [:tchevalier] from comment #12)
> Hi Josh,
> 
> Delphine told me to NI you on this one.
> Is that possible to uplift this patch to 2.2 please? This is low-risk and
> those locales are complete (or about to be complete), so that localizers can
> see their work and we can get them ready in case a partner requests any of
> them.

Hi Theo,
Yes, I agree. Please help to raise uplift request for 2.2 Thanks!
Flags: needinfo?(jocheng) → needinfo?(theo)
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8633159 [details] [review]
[gaia] TheoChevalier:new-gaia-locales > mozilla-b2g:master

(Oops, forgot about this approval flag thing)

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: am, dsb, hsb and zam locales can't be built-in in 2.2 builds.
[Testing completed]: Tested with latest master on Flame - new languages are available
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Flags: needinfo?(theo)
Attachment #8633159 - Flags: approval-gaia-v2.2?(jocheng)
Attachment #8633159 - Flags: approval-gaia-v2.2?(jocheng) → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.