[Aries][Dialer] Adding a contact from a listed number in Call Log will display placeholder UI in Dropdown Dialog

RESOLVED DUPLICATE of bug 1193503

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1193503
2 years ago
2 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

({regression, verifyme})

unspecified
ARM
Gonk (Firefox OS)
regression, verifyme

Firefox Tracking Flags

(b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing], [Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Description:
When a user attempts to add aa new contact to their contacts list from a received/sent call that is listed in their call log, they will observe a broken UI flow.

Repro Steps:
1) Update a Aries to 20150713103207
2) Call the phone
3) Observe call in call log
4) Hold tap on the call, access 'Call Information'
5) Tap 'Create New Contact'
6) Observe UI flow

Actual:
Drop down dialog from creating new contact in log has placeholder UI: 2 entries for 'Communications' and a checkbox

Expected:
No drop down dialog appears, contacts is opened (previous behavior exhibited in flame)

Environmental Variables:
-------------------------

Device: Aries 2.5
Build ID: 20150713103207
Gaia: a7439b6ca88264734171ff5ea0b6a0b8df3f258e
Gecko: 38d03bf4616e
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
***************************

Issue DOES NOT REPRODUCE on master for flame devices
Results: No drop down dialog appears, contacts is opened

Device: Flame 2.5
BuildID: 20150713010204
Gaia: e4b63559eba364892867eb381c3002d6518e5d6a
Gecko: eab21ec484bb
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
-------------------------

Repro frequency: 5/5
See attached: 
video- https://youtu.be/yhTGj1rYzHg
logcat
(Reporter)

Updated

2 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Comment 1

2 years ago
Created attachment 8633148 [details]
logcat_20150713_1532.txt
[Blocking Requested - why for this release]:
Bad visible regression

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
Unable to reproduce this bug on the reported build noted on comment 0 on Aries. Link to the reported build:
https://tools.taskcluster.net/task-inspector/#EaLrR3QURPOUAfITtyhUZA/

The reporter couldn't repro it either. Removing regression-window wanted due to inability to reproduce the bug. Perhaps we can NI someone on Dialer and see if they know anything about this.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: steps-wanted
Comms triage: Removing the noms until the steps are found.
blocking-b2g: 2.5? → ---
STR:

1.Flash the Aries device to this build:

BuildID: 20150619225606
Gaia: 4c06ed88ddccaba8dc941e5006bd2a9e57306f07
Gecko: 7c1a6b1151a1539186b950a144387e2d7f378d1b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

2. After flashing, change the dogfood channel to dogfood-latest and restart the device. 
3. Pull down the utility tray and download and install the system update.
4. After otaing to the latest build, make a phone call to the Aries device from another phone, let the phone ring a few times and then hang up the call. 
5. Tap on the "Dialer" icon and then tap on the "Call log".
6. Tap and hold your finger on the phone number of the missed call. 
7. Tap on "Call Information". 
8. Tap on "Create new contact". 

Notice a menu pops up that has "Communications" listed twice and a check box.
QA Whiteboard: [QAnalyst-Triage+]
Keywords: steps-wanted
Based on comment 5, I think this is the same root cause as bug 1193503. You need an OTA update to see the problem. Please verify this bug once bug 1193503 lands.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1193503
You need to log in before you can comment on or make changes to this bug.