[REGRESSION]History view is completely empty

VERIFIED FIXED in M12

Status

SeaMonkey
UI Design
P3
normal
VERIFIED FIXED
19 years ago
a year ago

People

(Reporter: Claudius Gayle, Assigned: Steve Lamm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
*Summary
        The History window comes up completely empty and tiny(bug 10987).

*To Repro
        1. Select Tasks|Tools|History.
	2. Look for window(top left of your screen, usually), expand.
	3. Observe.

*Build info
        This bug is XP and  was tested and reproduced on WinNTsp4 1999081210
MacOS 8.5.1 1999081208 and Linux RH6.0 1999081201?.

*Expected Result
        The contens of History should show up nicely displayed in a chromeless window.

*Actual Result
        Opening the history view window yields a thin or tiny window, bug 10987, but even
after you expand it there is absolutely nothing in the window. No column headers, no content.

*Waxing Intellectual
        Selecting Bookmarks|Manage Bookmarks sometimes yields this result on MAC (bug 11832)
but does it everytime on evry platform with history.
(Reporter)

Updated

19 years ago
Summary: History view view is completely empty → [REGRESSION]History view is completely empty
(Reporter)

Comment 1

19 years ago
smack. putting on chofmann radar. corrected typo in summary.

Updated

19 years ago
Assignee: slamm → waterson
Whiteboard: working on this

Comment 2

19 years ago
This would be probably be my fault. chofmann, this is a regression: should this
be M9?

Updated

19 years ago
Target Milestone: M9

Comment 3

19 years ago
yes lets get it on the radar

Updated

19 years ago
Assignee: waterson → slamm

Comment 4

19 years ago
Ok, claudius was right. This looks like slammage. I'm guessing the DTD stuff is
what broke this. slamm, can you take a look?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

19 years ago
Rats, I wish that stuff would fail more gracefully.
I will clean it up.

Updated

19 years ago
Whiteboard: working on this → have fix
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Whiteboard: have fix
(Assignee)

Comment 6

19 years ago
I checked in the fix.
(Reporter)

Updated

19 years ago
QA Contact: beppe → claudius
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
VERIFIED fixed for 1999081609 builds
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 8

19 years ago
reopening with the same exact M.O as described before.
(Reporter)

Updated

19 years ago
Resolution: FIXED → ---
(Reporter)

Comment 9

19 years ago
clearing the fixed resolution. I've reproduced this on Mac(mozilla build) and WinNT and Linux
with today's builds. yesterday's builds do not exhibit this regression so someone broke it last night.

Comment 10

19 years ago
*** Bug 15689 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Target Milestone: M9 → M10

Comment 11

19 years ago
claudius, check today M10 Win32...what do you get.  WE could release note this
for M10 if needed.
(Assignee)

Comment 12

19 years ago
I have a fix ready for this on the trunk.

Comment 13

19 years ago
this is *not* broken on M10 builds, just on the tip. Moving TFV to M11 to get
off M10 radar.
Target Milestone: M10 → M11
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

19 years ago
This has been fixed.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
yep
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.