repeatable crash in jvm.dll using (... rv:0.9.4) Gecko/20020102

VERIFIED DUPLICATE of bug 90571

Status

Core Graveyard
Java: OJI
--
critical
VERIFIED DUPLICATE of bug 90571
16 years ago
7 years ago

People

(Reporter: Marek Z. Jeziorek, Assigned: Joe Chou)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
1. goto https://netbenefits.401k.com/
2. login (you need a 401k retirement account with fidelity)
3. on the next screen click on the Fidelity Portfolio Planner link (lower right
corner)
4. press start button
5. a blank window pops up
6. get frustrated with the blank window and press x button on the right hand
corner to close it
7. crash

Updated

16 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 1

16 years ago
I'm not sure who to assign it to (most likely this ought to go to Sun's java team).


CAUSE: Access violation

Stack Trace (from talkback report
http://climate/reports/SingleIncidentInfo.cfm?dynamicBBID=1265601)


jvm.dll + 0x403f5 (0x6d4603f5)
jvm.dll + 0x40295 (0x6d460295)
jvm.dll + 0x22e31 (0x6d442e31)
jvm.dll + 0x22b9d (0x6d442b9d)
jvm.dll + 0x23e02 (0x6d443e02)
jpins32.dll + 0x87b0 (0x6d2e87b0)
jpins32.dll + 0x39f8 (0x6d2e39f8)
nsHTMLExternalObjSH::PostCreate
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 4009]
nsObjectFrame::NotifyContentObjectWrapper
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsObjectFrame.cpp, line 1908]
nsObjectFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsObjectFrame.cpp, line 1111]
nsLineLayout::ReflowFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 1023]
nsBlockFrame::ReflowInlineFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3477]
nsBlockFrame::DoReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3359]
nsBlockFrame::DoReflowInlineFramesAuto
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3284]
nsBlockFrame::ReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3229]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2375]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2045]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 800]
nsBlockReflowContext::DoReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
574]
nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
345]
nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2973]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2261]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2045]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 800]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 723]
CanvasFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLFrame.cpp, line 555]
nsBoxToBlockAdaptor::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 873]
nsBoxToBlockAdaptor::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 525]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 975]
nsScrollBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsScrollBoxFrame.cpp, line 379]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 975]
nsBoxFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 903]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 723]
ViewportFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 538]
nsHTMLReflowCommand::Dispatch
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowCommand.cpp, line 141]
PresShell::ProcessReflowCommand
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5989]
PresShell::ProcessReflowCommands
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6044]
PresShell::FlushPendingNotifications
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4992]
nsDocument::FlushPendingNotifications
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 3318]
nsHTMLExternalObjSH::GetPluginInstance
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 3938]
nsHTMLExternalObjSH::PostCreate
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 3997]
XPCWrappedNative::GetNewOrUsed
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 405]
XPCConvert::NativeInterface2JSObject
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcconvert.cpp, line 797]
nsXPConnect::WrapNative
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\nsXPConnect.cpp, line 497]
nsDOMClassInfo::WrapNative
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 760]
nsArraySH::GetProperty
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 3416]
nsNamedArraySH::GetProperty
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 3457]
XPC_WN_Helper_GetProperty
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 781]
js_GetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2375]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2573]
js_Execute [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 991]
JS_EvaluateUCScriptForPrincipals [d:\builds\seamonkey\mozilla\js\src\jsapi.c,
line 3327]
nsJSContext::EvaluateString
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 622]
nsScriptLoader::EvaluateScript
[d:\builds\seamonkey\mozilla\content\base\src\nsScriptLoader.cpp, line 576]
nsScriptLoader::ProcessRequest
[d:\builds\seamonkey\mozilla\content\base\src\nsScriptLoader.cpp, line 484]
nsScriptLoader::ProcessScriptElement
[d:\builds\seamonkey\mozilla\content\base\src\nsScriptLoader.cpp, line 428]
nsHTMLScriptElement::SetDocument
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLScriptElement.cpp,
line 140]
nsGenericHTMLContainerElement::AppendChildTo
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp,
line 3802]
HTMLContentSink::ProcessSCRIPTTag
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 5036]
HTMLContentSink::AddLeaf
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3435]
CNavDTD::AddLeaf [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 3769]
CNavDTD::HandleScriptToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 2224]
CNavDTD::OpenContainer [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3414]
CNavDTD::HandleDefaultStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1293]
Summary: repeatable crash using (... rv:0.9.4) Gecko/20020102 → repeatable crash in jvm.dll using (... rv:0.9.4) Gecko/20020102

Comment 2

16 years ago
does it still happen with 0.9.7?

Comment 3

16 years ago
.
Assignee: asa → joe.chou
Component: Browser-General → OJI
QA Contact: doronr → pmac

Comment 4

16 years ago
Same stack as in bug 90571.

*** This bug has been marked as a duplicate of 90571 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: pmac → petersen

Comment 5

15 years ago
vrfy dupe
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.