Hang with media.mediasource.format-reader

RESOLVED FIXED in Firefox 42

Status

()

defect
--
critical
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jruderman, Assigned: jya, NeedInfo)

Tracking

(Blocks 1 bug, {hang, testcase})

Trunk
mozilla42
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(2 attachments)

Posted file testcase
With:
  user_pref("media.mediasource.format-reader", true);

the testcase causes a shutdown hang, at least on Mac.
Been working on it all morning...
Assignee: nobody → jyavenard
The MediaFormatReader destructor is only called once all media task queues have shutdown.
However, the main thread demuxer always owned a reference to trackbuffer task queue.

The main thread demuxer is now only used with the old MSE.
Attachment #8633304 - Flags: review?(cpearce)
Blocks: 1182946
Blocks: 1171379
No longer blocks: 1182946
Attachment #8633304 - Flags: review?(cpearce) → review+
https://hg.mozilla.org/mozilla-central/rev/e988de526f82
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Flags: qe-verify+
I was not able to reproduce the bug using FF 42.0a1(20150701030207) and FF 42.0a1(20150713030204) using Mac OS X 10.9.5.
I've also tested on FF 42.0 beta4 (20151005144425) build and the issue was not reproducible.
Is there anyone that can reproduce this hang, taking in consideration that I couldn't reproduce the issue and confirm the actual result on an earlier build?

Thanks,
Mihai
Flags: needinfo?(jruderman)
You need to log in before you can comment on or make changes to this bug.