Border rendering regression on "callout box" up-arrow, at mrcoles.com and twitter.com

VERIFIED DUPLICATE of bug 1185636

Status

()

Core
Graphics
VERIFIED DUPLICATE of bug 1185636
3 years ago
3 years ago

People

(Reporter: brennie, Assigned: lsalzman)

Tracking

({regression})

41 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 unaffected, firefox41- fixed, firefox42- fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8633317 [details]
How it looks on Firefox 41 (Developer Edition)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150709004007

Steps to reproduce:

1. View http://mrcoles.com/blog/callout-box-css-border-triangles-cross-browser


Actual results:

The notch looks incorrect on Firefox 41+.


Expected results:

The notch should look as it does on Firefox 40.
(Reporter)

Comment 1

3 years ago
Created attachment 8633319 [details]
How it looks on Firefox 40 (Release)
(Reporter)

Updated

3 years ago
Attachment #8633317 - Attachment description: Firefox41.png → How it looks on Firefox 41 (Developer Edition)

Comment 2

3 years ago
I can reproduce the problem if HWA off.
Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics
Ever confirmed: true
Product: Firefox → Core

Comment 3

3 years ago
[Tracking Requested - why for this release]: renderling glich without HWA since 41 

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=98a929f58730&tochange=9e8d2b0dd0ce

Regressed by:
9e8d2b0dd0ce	Lee Salzman — Bug 1033375 - Nudge simple linear gradients with hard stops to half-pixel gradient. r=nical
Blocks: 1033375
status-firefox40: --- → unaffected
status-firefox41: --- → affected
status-firefox42: --- → affected
tracking-firefox41: --- → ?
tracking-firefox42: --- → ?
Flags: needinfo?(lsalzman)
Keywords: regression
(Assignee)

Updated

3 years ago
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Flags: needinfo?(lsalzman)
I see a version of this bug on Twitter as well. STR there:
 1. Log in to a twitter account.
 2. Visit https://twitter.com/ (stream of tweets from the people you follow)
 3. Click blank space in a tweet.
 --> Reply area pops open, with an uparrow.

Right now, in Nightly, this uparrow has some extremely weird dashed borders.  mozregression directed me to bug 1033375 as the cause, which directed me to this bug.

(There's a similar not-quite-so-gross issue in Twitter's "Messages" view, if I click on a message. They have a leftarrow pointing to the other person's face for each of their messages (kind of like a chat-bubble), and there are weird borders on that arrow too, presumably due to this same issue.)
Summary: Border rendering regression → Border rendering regression on "callout box" up-arrow, at mrcoles.com and twitter.com
Created attachment 8636105 [details]
screenshot of twitter

Here's a screenshot of Twitter. No visible border on this uparrow, pre-regression. (before bug 1033375 landed)
(Assignee)

Updated

3 years ago
Depends on: 1185636
I see this bug on the nextdoor.com neighborhood social network site, too, in responses to posts there. (The arrows on the responses look like the first screenshot here -- attachment 8633317 [details].)

Comment 7

3 years ago
Tracked as it's a regression.
tracking-firefox41: ? → +
tracking-firefox42: ? → +
(Assignee)

Comment 8

3 years ago
This should be fixed in 42 nightly as of the landing of the part 1 patch in bug 1185636. Once we get the patch uplifted to 41 we can consider this fixed.
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1185636
Removing 41 and 42 tracking as the original bug 1185636 is tracked and fixed on both 41 & 42.
status-firefox41: affected → fixed
status-firefox42: affected → fixed
tracking-firefox41: + → -
tracking-firefox42: + → -
Marking VERIFIED dupe -- I can confirm this is fixed at the site in comment 0 and at Twitter (per my STR in comment 4), using Nightly 43.0a1 (2015-08-18)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.