If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Note in Linux install docs that some distros require "a2enmod cgi" or other method of enabling CGI module

RESOLVED FIXED in Bugzilla 5.0

Status

()

Bugzilla
Documentation
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: gerv, Assigned: gerv)

Tracking

Bugzilla 5.0

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150712004007

Steps to reproduce:

Read http://serverfault.com/questions/705015/webserver-is-fetching-rather-than-executing-cgi-files . 


Actual results:

Someone followed the Linux instructions but wasn't told to "a2enmod cgi". This is in the quick start but not in the main instructions. 


Expected results:

We should fix that.

Comment 1

2 years ago
That guy already reported this bug. This was an error on his side.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1182823
(Assignee)

Comment 2

2 years ago
It still seems like some distros require CGI to be enabled, and we should document that.

Gerv
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Add "a2enmod cgi" to Linux install docs → Note in Linux install docs that some distros require "a2enmod cgi" or other method of enabling CGI module
(Assignee)

Comment 3

2 years ago
Created attachment 8641683 [details] [diff] [review]
Patch v.1

I've noted that not all distros require this, but some do, and explained how you tell if it's not been done.

Gerv
Assignee: documentation → gerv
Status: REOPENED → ASSIGNED
Attachment #8641683 - Flags: review?(LpSolit)

Comment 4

2 years ago
Comment on attachment 8641683 [details] [diff] [review]
Patch v.1

r=LpSolit
Attachment #8641683 - Flags: review?(LpSolit) → review+

Updated

2 years ago
Target Milestone: --- → Bugzilla 5.0
(Assignee)

Comment 5

2 years ago
To ssh://gitolite3@git.mozilla.org/bugzilla/bugzilla.git
   aeb6689..074b14f  master -> master

To ssh://gitolite3@git.mozilla.org/bugzilla/bugzilla.git
   2d2c85f..788dc9e  5.0 -> 5.0

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.