Make tabs tray interaction more Material

RESOLVED WONTFIX

Status

()

Firefox for Android
Theme and Visual Design
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: Paul [pwd], Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150513191204

Steps to reproduce:

The tabs tray aesthetically isn't up to par. I'm not sure what we're going for there but it looks like gingerbread and ICS had an ugly baby. Which may sound harsh and unfair, but when you look dated, you look really dated. Let's fix that.

If we absolutely can't switch to a carousel, let's at least decide to make it look better and look native.

We can improve the list-implementation for phone* and use cards for tablet.

* See the feed reader example on the cards page.
Anthony, do you agree? If so, do you have any ideas here?
Blocks: 1098596, 1157964
Flags: needinfo?(alam)
Thanks for your helpful feedback. 

But I think the ask here is rather vague. There's been a lot of tabs tray work going on and you can feel free to read about it here: https://medium.com/@antlam/a-new-mobile-tabs-tray-327ac262eacb

In the meantime, I'm going to close this since we have a bunch of other bugs filed and fixed (as seen in meta bug 1158277) and a direction we want to take the tabs tray in the future. 

We can address issues off of the meta bug 1194281.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(alam)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.