Very slow launch transition from suspended to active (staring at splash screen)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({perf})

unspecified
ARM
iOS

Firefox Tracking Flags

(fxios-)

Details

(Reporter)

Description

3 years ago
On my iPhone 6, I had Firefox suspended and went out to lunch, came back tapped the icon on my home-screen and saw Firefox launch and sit idle on the splash screen for maybe 8 seconds before the browser came up and my site restored
(Reporter)

Comment 1

3 years ago
I'm going to spend some time to see if I can reliably reproduce this.
(Reporter)

Comment 2

3 years ago
Ok this should do the trick; at least for me on my iPhone 6.

1. Load a site
2. Reboot device
3. Launch Firefox

See sadness: https://www.youtube.com/watch?v=LMiU0Dn6zHs
(Reporter)

Comment 3

3 years ago
This seems to be reproducible on Build #23 only but not on master.
Aaron, still affects 24?
Flags: needinfo?(aaron.train)
(Reporter)

Comment 5

3 years ago
Indeed
Flags: needinfo?(aaron.train)
tracking-fxios: ? → +
tracking-fxios: + → -
(Reporter)

Comment 6

3 years ago
Still see this, hoping it 'goes away' with in-store build
How is this now, Aaron?
Flags: needinfo?(aaron.train)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(aaron.train)
Resolution: --- → WORKSFORME

Comment 8

2 years ago
I still see this. In fact, as per my recollection, the first time I tried Firefox for iOS, my immediate observation was that it was quite slow to launch. While a native app like Safari opens up in about 2 seconds, Firefox takes about 4 or more seconds. For new users, this can make them impatient as they'd feel like they are waiting too long. One option, if we can't get rid of the delay, would be to incrementally display UI elements as they are loaded. Instead of the splash screen. This would at least make users less impatient.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 9

2 years ago
Do you have steps to replicate the issue reliably?
Flags: needinfo?(maurya1985)

Comment 10

2 years ago
Aaron, I just updated to v5.3 (up from 5.0) and it opens up in 2 seconds. So, I don't see the issue anymore. I hadn't listed any steps as such because I was referring to a cold and fresh launch of the app.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Flags: needinfo?(maurya1985)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.