Closed Bug 1183766 (malayalam-keyboard) Opened 7 years ago Closed 4 years ago

Add Malayalam (ml) keyboard layout

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: tchevalier, Unassigned)

References

Details

This is a request to create a keyboard layout for Malayalam (ml) locale.

Localizers have been CC'ed to provide feedback on the layout once provided and/or provide additional guidance if initial work already exists or if there are some specificities for this locale.

If you only need an existing layout with some changes and/or a dictionary for your language, please mention it here as well. A bug to create a dictionary for your locale has already been filed out.
Last year we have done some work on Creating a Firefox OS Indic IME as a part of 2014 Google summer of code under Swathanthra Malayalam Computing , the Indian Language technology collective https://gitlab.com/smc/firefoxos-ime
Santhosh Thottingal, Tim  , Rudy and myself mentored this project 


For Android we are maintaining Indic Keyboard , very popular AOSP based free and open source keyboard which supports 23 Languages and 50+ layouts (Many South Asian languages). It is used by more than 200K people via play store
https://gitlab.com/smc/indic-keyboard


https://github.com/androidtweak/dictionaries have dictionaries and wordlists used for Indian Languages 

Indic keyboard for Android uses popular Keyboards in each language . I love to see similar functionality  in Firefox OS.

Adding some more people in Bug . Also ccing delphine
Alias: malayalam-keyboard
Duplicate of this bug: 1135482
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.