Status

Webtools
DXR
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: keeler, Assigned: fubar)

Tracking

Trunk

Firefox Tracking Flags

(firefox42 affected)

Details

dxr.mozilla.org doesn't seem to have a recent version of mozilla-central. Changes that went into the tree about a week ago (e.g. rev. 31d0ae4d8c62) aren't there.
(Assignee)

Comment 1

3 years ago
the comm-central build has been failing and blocking the whole thing. I'll look into it and see if I can unstick it.
(Assignee)

Comment 2

3 years ago
until then, might I suggest https://dxr.allizom.org/mozilla-central/source/
FWIW, comm-central was broken because it's building SeaMonkey instead of Thunderbird--and SeaMonkey has been broken for quite a while, while Thunderbird hasn't been.
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1184113
(Assignee)

Comment 5

3 years ago
aha, it looks like we were originally building thunderbird until something went off the rails in c-c and we switched over to seamonkey with the intent to revert, but lost the train of thought.  Oops. :-(

I'll go switch it back over to Tbird and start a build to get m-c and c-c on dxr.m.o.
Assignee: nobody → klibby
(Assignee)

Comment 6

3 years ago
josh - still failing after changing to tbird:

In file included from /targetdata/dxr-build-env/src/comm-central/mailnews/mime/cthandlers/pgpmime/nsPgpMimeProxy.cpp:22:
In file included from ../../../../dist/include/mimemoz2.h:15:
../../../../dist/include/nsMsgAttachmentData.h:101:20: error: explicit specialization of non-template struct 'HasDangerousPublicDestructor'
template <> struct HasDangerousPublicDestructor<nsMsgAttachmentData>
                   ^                           ~~~~~~~~~~~~~~~~~~~~~
../../../../dist/include/nsMsgAttachmentData.h:105:20: error: explicit specialization of non-template struct 'HasDangerousPublicDestructor'
template <> struct HasDangerousPublicDestructor<nsMsgAttachedFile>
                   ^                           ~~~~~~~~~~~~~~~~~~~
../../../../dist/include/nsMsgAttachmentData.h:105:20: error: redefinition of 'HasDangerousPublicDestructor'
../../../../dist/include/nsMsgAttachmentData.h:101:20: note: previous definition is here
template <> struct HasDangerousPublicDestructor<nsMsgAttachmentData>
                   ^
In file included from /targetdata/dxr-build-env/src/comm-central/mailnews/base/util/nsMsgReadStateTxn.cpp:6:
/targetdata/dxr-build-env/src/comm-central/mailnews/base/util/nsMsgReadStateTxn.h:45:26: warning: private field 'mWasMarkedRead' is not used [-Wunused-private-field]
  bool                   mWasMarkedRead;
                         ^
3 errors generated.

In the directory  /targetdata/dxr-build-env/obj/comm-central/mailnews/mime/cthandlers/pgpmime
The following command failed to execute properly:
clang++ -Xclang -load -Xclang /targetdata/dxr-build-env/dxr-venv/lib/python2.7/site-packages/dxr-0.1-py2.7.egg/dxr/plugins/clang/libclang-index-plugin.so -Xclang -add-plugin -Xclang dxr-index -Xclang -plugin-arg-dxr-index -Xclang /targetdata/dxr-build-env/src/comm-central -o nsPgpMimeProxy.o -c -I../../../../dist/stl_wrappers -I../../../../dist/system_wrappers -include /targetdata/dxr-build-env/src/comm-central/mozilla/config/gcc_hidden.h -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -I/targetdata/dxr-build-env/src/comm-central/mailnews/mime/cthandlers/pgpmime -I. -I/targetdata/dxr-build-env/src/comm-central/mailnews/mime/cthandlers/pgpmime/../glue -I../../../../dist/include -I/targetdata/dxr-build-env/obj/comm-central/dist/include/nspr -I/targetdata/dxr-build-env/obj/comm-central/dist/include/nss -fPIC -Qunused-arguments -DMOZILLA_CLIENT -include ../../../../mozilla-config.h -MD -MP -MF .deps/nsPgpMimeProxy.o.pp -Qunused-arguments -Qunused-arguments -Wall -Wempty-body -Woverloaded-virtual -Wsign-compare -Wwrite-strings -Wno-invalid-offsetof -Wno-c++0x-extensions -Wno-extended-offsetof -Wno-unknown-warning-option -Wno-return-type-c-linkage -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -I/targetdata/dxr-build-env/src/comm-central/mozilla/build/unix/headers -pthread -pipe -DDEBUG -DTRACING -g -fno-omit-frame-pointer /targetdata/dxr-build-env/src/comm-central/mailnews/mime/cthandlers/pgpmime/nsPgpMimeProxy.cpp
make[4]: *** [nsPgpMimeProxy.o] Error 1
make[3]: *** [mailnews/mime/cthandlers/pgpmime/target] Error 2
Flags: needinfo?(Pidgeot18)
(In reply to Kendall Libby [:fubar] from comment #6)
> josh - still failing after changing to tbird:
> 
> In file included from
> /targetdata/dxr-build-env/src/comm-central/mailnews/mime/cthandlers/pgpmime/
> nsPgpMimeProxy.cpp:22:
> In file included from ../../../../dist/include/mimemoz2.h:15:
> ../../../../dist/include/nsMsgAttachmentData.h:101:20: error: explicit
> specialization of non-template struct 'HasDangerousPublicDestructor'
> template <> struct HasDangerousPublicDestructor<nsMsgAttachmentData>
>                    ^                           ~~~~~~~~~~~~~~~~~~~~~

Bug 1183729.
Flags: needinfo?(Pidgeot18)

Comment 8

3 years ago
dxr seems to have updated 5 days ago on July 23, but not since then...
(Assignee)

Comment 9

3 years ago
gtk3 bustage.

after working around a different issue, m-c and c-c are building again on dxr.allizom.org, so that's an option. I'll chat with Erik today about cutting prod over to ES, which will be easier than fixing the old build system.
DXR 2.0 is now in production. As a result, DXR builds of moz-central and comm-central are now up to date, and they'll tend to stay that way, since one failing build won't scuttle the other trees.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.