"ERROR null" appears in Sync logs

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
24 days ago

People

(Reporter: markh, Assigned: markh)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
Created attachment 8633836 [details] [diff] [review]
0001-Bug-XXXXXXX-only-log-an-error-saving-JSON-if-an-erro.patch

Sync logs may include an entry similar to:

1436815520239	Sync.Engine.History	ERROR	null

This is more of a problem since bug 1148980 landed as any "error" entry in the logs cause Sync to generate an error log and note the error in the browser console.

Although I haven't yet reproduced this, I'm confident the problem is https://hg.mozilla.org/mozilla-central/file/e7e69cc8c07b/services/sync/modules/engines.js#l786. This is the callback from Utils.jsonSave, which is at https://hg.mozilla.org/mozilla-central/file/e7e69cc8c07b/services/sync/modules/util.js#l369, and as you can see, the callback is made with null when there's no error - but we still log it.
Attachment #8633836 - Flags: review?(rnewman)
(Assignee)

Comment 1

3 years ago
Created attachment 8633837 [details] [diff] [review]
0001-Bug-XXXXXXX-only-log-an-error-saving-JSON-if-an-erro.patch

Actually, let's make the error more descriptive while we are at it.
Assignee: nobody → markh
Attachment #8633836 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8633836 - Flags: review?(rnewman)
Attachment #8633837 - Flags: review?(rnewman)
Attachment #8633837 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/mozilla-central/rev/e37fbad568b7
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.